All users were logged out of Bugzilla on October 13th, 2018

Are these BCC & Co localization notes to be taken seriously?

RESOLVED FIXED in Thunderbird 5.0b1

Status

--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: smolejv, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 5.0b1

Firefox Tracking Flags

(blocking-thunderbird5.0 needed, blocking-thunderbird3.1 -)

Details

(Whiteboard: [has patch for review])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
It is TB, files /mail/chrome/messenger/mime.properties and mimeheader.properties

http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/sl/diff/f791b41b8768/mail/chrome/messenger/mime.properties
http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/sl/diff/ff4b54422eb7/mail/chrome/messenger/mime.properties
http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/sl/diff/f791b41b8768/mail/chrome/messenger/mimeheader.properties
http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/sl/diff/ff4b54422eb7/mail/chrome/messenger/mimeheader.properties

Please note that BCC, CC etc are as central to the application as "File" is to say Firefox.

There's only two possibilities:
a) They must be taken seriously, not because "it says so", but for some reason in the code. In this case the code must corrected PDQ to eliminate this kind of language dependence.

or

b) there's no reason for not localizing the entries. The comments should be corrected, so that there's no more room for misunderstanding. 
.
(Reporter)

Comment 1

8 years ago
Note that this has nothing to do with sl localization and everything with the en_US prototype. Reassign accordingly - if feasible/possible.

Regards

Vito
(Assignee)

Comment 2

8 years ago
I don't believe there's a reason not to localize the entries, other than the fact that the actual mail headers are CC:, BCC:, etc. But since we localize these in other aspects of message display, then we should allow them to be localized in forward inline messages.
(Assignee)

Updated

8 years ago
Component: sl / Slovene → Mail Window Front End
Product: Mozilla Localizations → Thunderbird
QA Contact: slovene.sl → front-end
(Assignee)

Updated

8 years ago
Version: unspecified → Trunk
Duplicate of ye olde bug 125446. They were added without discussion (outside of discussion within Netscape's offices) by bug 39775, perhaps without realizing that they would affect both printing and forward inline, and then bug 125446 stalled because of the [citation needed] assertion in bug 125446 comment 4 that "For forward inline, if we translate it, we will have problem."
(Assignee)

Comment 4

8 years ago
Thx Phil. I'm skeptical that we will have problems w/ forward inline, other than the fact that the localization can escape the locale, so if someone using a localization in a language I don't know (i.e, almost all of them) forwards a message to me, the headers won't make sense.
Oh, yeah. I knew I'd gone on at even greater length about that stuff somewhere. Bug 471487.
I'm putting this on the blocking radar for the next release off branch and trunk. This is mainly as I think we need to do an investigation into this to a) get a reasonable statement for Vito and other localisers about what is should be done on branch, and b) follow-up with any appropriate (l10n affecting) fixes on the trunk.
blocking-thunderbird3.1: --- → .6+
Flags: blocking-thunderbird-next+
blocking-thunderbird5.0: --- → needed
Flags: blocking-thunderbird-next+
blocking-thunderbird3.1: .7+ → .8+
blocking-thunderbird3.1: .8+ → needed
David, I'm not getting to this, can you try and get some sense into those l10n notes please?
Assignee: nobody → dbienvenu
(Assignee)

Comment 8

8 years ago
OK, after reading the relevant bugs, I think the thing to do is change the comments to say that you *can* translate the strings, but the translated strings will be used when you forward a message to users in a different locale.
(Assignee)

Comment 9

8 years ago
Created attachment 527449 [details] [diff] [review]
remove the comments

I decided just to remove the comments - we don't have similar comments for the other headers like subject or from (i.e., those localizations "escape" to other locales already), and from what I can tell, everyone is localizing those strings anyway. Also, mimeheaders.properties doesn't tend to get used (it's a fallback for missing strings, from what I can tell).
Attachment #527449 - Flags: review?(bugzilla)
(Assignee)

Updated

8 years ago
Whiteboard: [has patch for review]
Attachment #527449 - Flags: review?(mbanner) → review+
(Assignee)

Comment 10

8 years ago
http://hg.mozilla.org/comm-central/rev/ba5211b37c84
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a4
Decided not to take this on 3.1, as 3.1 isn't going to be actively used by localisers now.
blocking-thunderbird3.1: needed → -
You need to log in before you can comment on or make changes to this bug.