Intermittent cascade of failure starting with browser_tabview_dragdrop.js | Test timed out

RESOLVED FIXED in Firefox 4.0

Status

Firefox Graveyard
Panorama
P3
normal
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: Phil's Orange Reporter, Assigned: raymondlee)

Tracking

({intermittent-failure})

Trunk
Firefox 4.0
intermittent-failure
Dependency tree / graph

Details

(Whiteboard: , [qa-])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
While it's possible that these are all separate things, I find it rather unlikely that in one run, we suddenly hit never-before-seen failures in nine different tests, and much more likely that neither browser_tabview_dragdrop.js nor any of the rest use registerCleanupFunction() to clean up after themselves in case of timeout, nor establish the conditions they need when they start up, so once the first one tripped, they all fell down on top of it.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1286843690.1286844768.9850.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2010/10/11 17:34:50
s: talos-r3-fed64-048

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_dragdrop.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_dragdrop.js | Found a tab after previous test timed out: about:blank
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_dragdrop.js | Found a tab after previous test timed out: about:blank
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_exit_button.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_firstrun_pref.js | Main window TabView is hidden
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_firstrun_pref.js | Main window TabView is still hidden
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_group.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_launch.js | Tab View starts hidden
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_launch.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_multiwindow_search.js | Tab View is hidden
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_multiwindow_search.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_multiwindow_search.js | Found a browser window after previous test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_multiwindow_search.js | Found a browser window after previous test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_search.js | Tab View is hidden
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_search.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_search.js | Found a tab after previous test timed out: http://mochi.test:8888/
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_search.js | Found a tab after previous test timed out: about:blank
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_snapping.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_undo_group.js | Test timed out
Comment hidden (Treeherder Robot)

Comment 2

7 years ago
Is this still an issue?
Target Milestone: --- → Future
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to comment #2)
> Is this still an issue?

Heh.

Updated

7 years ago
Target Milestone: Future → ---

Updated

7 years ago
OS: Linux → All
Hardware: x86_64 → All
Ian, have you tried to reproduce this locally?  (By running the suite over and over again on a machine)

Updated

7 years ago
Depends on: 585689
Target Milestone: --- → Firefox 4.0

Comment 8

7 years ago
Probably not super high priority, but something we should for hygiene reasons get to before 1.0

Updated

7 years ago
Priority: -- → P3
Assignee: nobody → raymond
Blocks: 597043
Seems like this is two bugs: 

* browser_tabview_dragdrop.js is flakey (and has recently become more so?)

* We should use registerCleanupFunction in our tests. 

This bug should concentrate on the former; I've created bug 603820 for the latter.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 17

7 years ago
Created attachment 483417 [details] [diff] [review]
v1

The test stops when simulateDragDrop() is invoked and looked like something goes wrong inside that method.  Simplified the simulateDragDrop() would hopefully fix the problem.
Attachment #483417 - Flags: feedback?(ian)
Comment hidden (Treeherder Robot)
Comment on attachment 483417 [details] [diff] [review]
v1

>+  let incrementX = offsetX / 2;
>+  let incrementY = offsetY / 2;
> 
>   EventUtils.synthesizeMouse(
>+    element, startX, startY, { type: "mousedown" });
>+  
>+  for (let i = 1; i <= 3; i++) {
>+    EventUtils.synthesizeMouse(
>+      element, (startX + incrementX * i), (startY + incrementY * i), 
>+      { type: "mousemove" });
>+  }
> 
>+  EventUtils.synthesizeMouse(
>+    element, (startX + incrementX * 2), (startY + incrementY * 2), 
>+    { type: "mouseup" });

Looks like the drag overshoots the mark by half but then drops on the mark. Why the overshoot?

Otherwise looking good.
Attachment #483417 - Flags: feedback?(ian) → feedback+
Comment hidden (Treeherder Robot)
(Assignee)

Comment 21

7 years ago
Created attachment 483696 [details] [diff] [review]
v1

Fixed the comments Ian mentioned.

f+=ian
Attachment #483417 - Attachment is obsolete: true
Attachment #483696 - Flags: review?(dolske)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 483696 [details] [diff] [review]
v1

rs=me
Attachment #483696 - Flags: review?(dolske) → review+
(Assignee)

Comment 33

7 years ago
Created attachment 485655 [details] [diff] [review]
Patch for check-in

r=dolske
Attachment #483696 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
http://hg.mozilla.org/mozilla-central/rev/caa59a0d7910
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Keywords: checkin-needed

Updated

7 years ago
Whiteboard: [orange] → [orange][qa-]

Updated

7 years ago
Whiteboard: [orange][qa-] → [orange], [qa-]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Blocks: 653099
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
bugspam
No longer blocks: 653099
bugspam
Blocks: 660175
Adding intermittent test failures to new meta bug.

(bugspam)
Blocks: 665844
I accidently re-opened, though it's actually another failure. Closing again and filed bug 667884.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
Keywords: intermittent-failure
Whiteboard: [orange], [qa-] → , [qa-]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.