Closed Bug 603557 Opened 9 years ago Closed 9 years ago

[SeaMonkey] TEST-UNEXPECTED-FAIL | Lots of intermittent failures for mochitest-browser-chrome in toolkit/mozapps/extensions/test/browser/

Categories

(Toolkit :: Add-ons Manager, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b7

People

(Reporter: bugzilla, Assigned: bugzilla)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

There are failures for browser_install.js, browser_list.js, browser_recentupdates.js and browser_uninstalling.js. The first one times out, so perhaps the other failures are the result of that timeout.

This only happens on our Linux tinderbox, example log: http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1286861469.1286863917.16677.gz

Checkins in the regression range:

http://hg.mozilla.org/comm-central/pushloghtml?fromchange=bfd1320b39ac&tochange=e957ea752a74

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a8212bca66fb&tochange=5a41a70eb631
Yeah, I had noticed it after the last perma-oranges failures were fixed.

It seems to be +/- all platforms. For example:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1286831834.1286836620.11879.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2010/10/11 14:17:14
Blocks: 438871
Component: Testing Infrastructure → Add-ons Manager
OS: Linux → All
Product: SeaMonkey → Toolkit
QA Contact: testing-infrastructure → add-ons.manager
Summary: TEST-UNEXPECTED-FAIL | Lots of fails for mochitest-browser-chrome in toolkit/mozapps/extensions/test/browser/ → [SeaMonkey] TEST-UNEXPECTED-FAIL | Lots of intermittent failures for mochitest-browser-chrome in toolkit/mozapps/extensions/test/browser/
Whiteboard: [orange]
I've found the reason for the first failure, browser_install.js simply takes too long. The test passed on my local machine in 14.766s, so I've summed up the the times from the single tests and got to 28.659s until test 12 starts. So we hit a timeout during test 12 and never get to test 13.

Firefox is also affected: http://brasstacks.mozilla.com/topfails/test/Firefox?name=chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js

@Dave: You wrote the test, could it be split somehow or get a longer timeout?
No longer blocks: SmTestFail
It could, but it's easier to just extend the timeout.
I think factor 2 should be enough, but we'll have to wait what for the actual tinderbox runs.
Assignee: nobody → aqualon
Status: NEW → ASSIGNED
Attachment #482584 - Flags: review?(dtownsend)
Attachment #482584 - Flags: review?(dtownsend) → review+
Keywords: checkin-needed
Checked in as http://hg.mozilla.org/mozilla-central/rev/e3701c6f77fd

Waiting for test results, if it was enough before marking it fixed.
Keywords: checkin-needed
I don't see the timeout anymore for SeaMonkey and the following tests are passing too, so marking as fixed.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
http://brasstacks.mozilla.com/topfails/test/SeaMonkey?name=chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js
First = 2010-10-07 00:32 SeaMonkey Linux
Last  = 2010-10-12 16:33 SeaMonkey WINNT 5.2

V.Fixed

***

Though the last 3 seems to be after check-in time:
{
# 2010-10-12 16:33 SeaMonkey WINNT 5.2   [3fb3186c8172]
# 2010-10-12 13:42 SeaMonkey WINNT 5.2   [3fb3186c8172]
# 2010-10-12 13:00 SeaMonkey Linux   [3fb3186c8172]
}

Much better anyway, ftb.
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
Target Milestone: --- → mozilla2.0b8
No longer depends on: 608210
Target Milestone: mozilla2.0b8 → mozilla2.0b7
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.