Bug 604019 (fx40-p12n-tr)

[tr] Firefox 4.0 productization review for Turkish

RESOLVED FIXED

Status

Mozilla Localizations
tr / Turkish
P2
normal
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: stas, Assigned: rail)

Tracking

({productization})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [l10n-src-verification updated])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
As you might have seen in the newsgroups or on the Mozilla blog, there's a couple of changes to search engines planned for the 4.0 release for en-US: <http://groups.google.com/group/mozilla.dev.l10n/msg/81073d8d67e1c4c3>. We would like to use this opportunity to review the current productization setup for Turkish and make any changes that you think will be good for our users.

What is a productization review?
================================

Here's what we're interested in:
* search engines,
* protocol handlers,
* feed readers,
* live bookmark.
You can see what your locale currently ships with at <http://hg.mozilla.org/l10n/l10n-src-verification/file/default/reference/browser/2.0/tr>

Please take a moment and review the choice of services available by default in your locale. If there have been any new services that have recently gained popularity and that offer good value for the users, please suggest adding them to your locale. On the other hand, if there are services that lost credibility (e.g. display too many adds) or have poor user experience, consider suggesting that we remove them. If in doubt, feel free to make a suggestion and we'll look at it together. You might find the guidelines at <https://wiki.mozilla.org/L10n:Productization> and <https://wiki.mozilla.org/L10n:Firefox/Productization> helpful, too.

Required changes
================

There's two things I would like to draw your attention to (if applicable):

1) if you have a google.xml file in your `searchplugins` directory, please remove it,

2) Bloglines is closing down on November 1st and we need to remove it from the feed reader options for all locales (see bug 595485). We suspect that it will make sense to move Google Reader up to the first position (if your locale has it). We will be offering technical help with this change, either in form of ready-made patches or a mass-landing by one of the l10n-drivers. If you don't think that moving Google Reader up is a good idea for your locale, please let us know!

Changes in en-US and en-GB
==========================

Here's the changes that we will be making in en-US and en-GB:
* add Bing as the 3rd general search engine (see bug 603298),
* remove Answers,
* remove Creative Commons.

We're making these changes in en-US and en-GB because we feel that they follow the recent market trends and user preferences in the US and the UK. We would like to go through the same thought process for your locale and see if any of these changes would make sense in Turkish builds as well. If you decide that implementing these changes would be in your users' best interest then please go ahead and include them in the patch you'll attach to this bug.


Implementation
==============

Please make suggestions for changes and attach patches that Seth, Axel or I will review. Please note that since Bing provides a global plugin which does the locale detection itself, you will only need to add "bing" to your list.txt if you decide to include it. The XML file will be automatically pulled from en-US.

Once a review is granted, you can land the patch on l10n-central if your locale actively maintains it. Otherwise, please wait for further instructions which will be put in the comments of this bug and announced in mozilla.dev.l10n (we're still unsure when the branching will happen). Please do not land any changes except for the required ones (google.xml, Bloglines) on 1.9.2.

If you do not wish to make any changes, let us know, and we'll only work on removing Bloglines.

Thanks!

Comment 1

8 years ago
Created attachment 493640 [details] [diff] [review]
tr patch for 2.0

These changes have been discussed in our localization group and implemented in the patch:
* Yahoo! USA search engine replaced by the recently launched Yahoo! Turkey search engine.
* Answers and Creative Commons removed. We have decided not to add Bing, since they haven't provided a search experience for Turkey yet.
* Bloglines replaced by Google Reader.
Comment on attachment 493640 [details] [diff] [review]
tr patch for 2.0

Staś,  could you take a look and review the patch?
Attachment #493640 - Flags: review?(stas)
(Reporter)

Comment 3

8 years ago
Comment on attachment 493640 [details] [diff] [review]
tr patch for 2.0

Technically this looks good, but give me a couple of hours before the US wakes up so that I can confirm the search params for Turkish Yahoo!. I'll review again then.

Comment 4

8 years ago
Looks good to me. Will verify w/Y!, but proceed, because it should be fine.
(Reporter)

Comment 5

8 years ago
Comment on attachment 493640 [details] [diff] [review]
tr patch for 2.0

Actually, this isn't technically good.

You'll need to rename the yahoo.xml file to yahoo-tr.xml in order for the change in list.txt to work.

Also, can you hg remove the extraneous xml files in https://hg.mozilla.org/l10n-central/tr/file/f6b6573f9f8f/browser/searchplugins ? These are: amazondotcom.xml, answers.xml, creativecommons.xml, eBay.xml, google.xml, wikipedia.xml and yahoo.xml. As long as you keep their names in list.txt, the actual xml files will be automatically pulled from en-US during build, so there's no need to keep the, in your repo. This applies to both 1.9.2 and central.

Can you also attach a patch which removes Bloglines on 1.9.2?

Thanks!
Attachment #493640 - Flags: review?(stas) → review-
Created attachment 494044 [details] [diff] [review]
Firefox 4.0 productization patch

(In reply to comment #5)
> Comment on attachment 493640 [details] [diff] [review]
> tr patch for 2.0
> 
> Actually, this isn't technically good.
> 
> You'll need to rename the yahoo.xml file to yahoo-tr.xml in order for the
> change in list.txt to work.

Actually it was renamed, see the following snippet:

diff --git a/browser/searchplugins/yahoo.xml b/browser/searchplugins/yahoo-tr.xml
rename from browser/searchplugins/yahoo.xml
rename to browser/searchplugins/yahoo-tr.xml
--- a/browser/searchplugins/yahoo.xml
+++ b/browser/searchplugins/yahoo-tr.xml


> Also, can you hg remove the extraneous xml files in
> https://hg.mozilla.org/l10n-central/tr/file/f6b6573f9f8f/browser/searchplugins
> ? These are: amazondotcom.xml, answers.xml, creativecommons.xml, eBay.xml,
> google.xml, wikipedia.xml and yahoo.xml. As long as you keep their names in
> list.txt, the actual xml files will be automatically pulled from en-US during
> build, so there's no need to keep the, in your repo. This applies to both 1.9.2
> and central.

Yeah, you are right. See attached patch.

> Can you also attach a patch which removes Bloglines on 1.9.2?

Coming next.
Attachment #493640 - Attachment is obsolete: true
Attachment #494044 - Flags: review?(stas)
Created attachment 494047 [details] [diff] [review]
Firefox 3.6 productization patch

> Can you also attach a patch which removes Bloglines on 1.9.2?

Attached removes Bloglines and moves Google to the first place. I haven't touched any of search plugins.
Attachment #494047 - Flags: review?(stas)
(Reporter)

Comment 8

8 years ago
Comment on attachment 494044 [details] [diff] [review]
Firefox 4.0 productization patch

r=me, thanks. 

Interestingly, the renaming doesn't show up on https://bugzilla.mozilla.org/attachment.cgi?id=494044&action=diff nor on https://bugzilla.mozilla.org/attachment.cgi?id=494044&action=diff&context=patch&collapsed=&headers=1&format=raw which is what made me mention it. Sorry for the noise.

(TIL that the "Raw unified" link on the attachment's Diff page does not necessarily show the same diff as the actual patch that was attached; cf. https://bugzilla.mozilla.org/attachment.cgi?id=494044&action=diff&context=patch&collapsed=&headers=1&format=raw vs. https://bug604019.bugzilla.mozilla.org/attachment.cgi?id=494044)

Please land this patch on central, mentioning this bug and my review.
Attachment #494044 - Flags: review?(stas) → review+
(Reporter)

Comment 9

8 years ago
Comment on attachment 494047 [details] [diff] [review]
Firefox 3.6 productization patch

r=me. Please land this patch on 1.9.2, mentioning this bug and my review.

Thanks, Selim and Rail!
Attachment #494047 - Flags: review?(stas) → review+
Assignee: erkan → rail
Priority: -- → P2
All done here.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 13

8 years ago
Nice work!  Please don't forget to sign off on your work so it gets picked up in the next set of releases.
(Reporter)

Comment 14

8 years ago
https://hg.mozilla.org/l10n/l10n-src-verification/rev/295a0e1f3e0e
Whiteboard: [l10n-src-verification updated]
You need to log in before you can comment on or make changes to this bug.