Installed skin/theme being used, despite being version incompatible. As a result, incorrect menu shown when right-clicking on empty space on tab bar.

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: kaie, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I've just recently started to use my primary Firefox work profile with Firefox 4.

In this profile, when I right-click on any tab in the tab bar, I get the toolbar menu, not the tab menu.

In other words, the menu shown offers
  "nav toolbar, bookmarks toolbar, tabs on top, customize"

But I expect it show a menu that contains the usual tab options like
  "New Tab, ..., Close Tab, ..., Undo closed Tab"
(Reporter)

Comment 1

8 years ago
This is seen with Firefox 4 Beta 6 on Linux, using a contributed Fedora build.

I did some experiments in order to find the culprit.

* Disabled all add-ons => still same bug
* Reset toolbars and controls => still same bug
* Reset all user preferences to Firefox defaults => makes it work


Obviously I don't want to lose all my individual preferences that I've collected over time, I've restored a backup that I made prior to the above experiments.


This bug requests that we track down the old preference or migrated preference that is responsible for showing the incorrect menu.
(Reporter)

Comment 2

8 years ago
Found the culprit.

I have preference
  general.skins.selectedSkin
set to
  "charamel"

The "charamel" skin is installed, but it is disabled, according to the add-one manager, because it's incompatible with ff4b6.

Despite being disabled, it still has the effect to disturb the right click menus.
(Reporter)

Updated

8 years ago
Summary: Incorrect menu shown for right-click-on-tab, using migrated profile → Installed skin/theme being used, despite being version incompatible. As a result, incorrect menu shown for right-click-on-tab.
(Reporter)

Comment 3

8 years ago
While add-on manager claimed the skin/theme is incompatible, it was used. I saw the non-standard user interface colours.

As far as I understand, I *don't* have any prefs set that would disable addon compatibility checking as explained in http://kb.mozillazine.org/Updating_extensions#Completely_disabling_the_compatibility_check
(Reporter)

Comment 4

8 years ago
Ok, maybe I did something in the past that I shouldn't have done.

Here is how this issue can be reproduced:

- start firefox 3.6.x with a fresh profile
- install https://addons.mozilla.org/en-US/firefox/addon/14313/
- restart
- uninstall the "addon", but keep the "theme"
- restart
- you still have the charamel colours
- quit
- now start firefox 4 with the same profile
- you still see the charamel colours and you see the bug
Severity: major → normal

Updated

8 years ago
Component: Tabbed Browser → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: tabbed.browser → add-ons.manager
Bug 565064 was meant to have fixed this but that landed for b2.

Can you attach a copy of extensions.sqlite from your profile folder.
Works fine for me with Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre. The migration wizard correctly identifies the Carmel theme as incompatible and disables it. Kai, can you please test with a todays Minefield build?
(Reporter)

Comment 7

8 years ago
I just ran into this again, with the latest Linux nightly build from mozilla.org

I had only one incompatible addon installed (littlefox), it was disabled, but still, I had the incorrect menu (missing undo-tab-close).

In order to fix it for me, I had to:
- uninstall littlefox
- restart
- still broken
- install a random theme compatible with 4.0,
  I picked https://addons.mozilla.org/en-US/firefox/addon/191969/
- restart
- get the black theme, menu still broken
- go to addon-manager, enable the default theme
- restart
- finally I get the expected menu
(Reporter)

Comment 8

8 years ago
Created attachment 490270 [details]
extensions.sqlite.zip

I'm  still able to reproduce the bug with a fresh profile and the steps from comment 4.

Here is a zipped extensions.sqlite as requested, from that broken profile.
Attachment #490270 - Flags: review?(dtownsend)
Comment on attachment 490270 [details]
extensions.sqlite.zip

I still can't reproduce this and the database appears to match what I get after following the steps so I'm not sure why we're not switching back to the default theme. Could you try the process again with extensions.logging.enabled set to true and then when you start Firefox 4 for the first time on the profile do so from a terminal and copy anything that gets logged.
Attachment #490270 - Flags: review?(dtownsend)
(Reporter)

Comment 10

7 years ago
Maybe this is invalid.

Today I realized I specific behaviour of the right click menus.
It might be that this special behaviour had confused me in the past when reporting this bug.

My observation:

- a right click on an open tab bar produces the expected tab menu

- a right click on the empty area to the right on tabs produces the
  unexpected toolbar selector menu


I have verified, using old Firefox 3, the same menu was displayed for both areas.


If this new behaviour is the intended behaviour, then this bug is invalid, but more people might experience the same confusion .
Right, this is invalid and is not related to any theme/skin installed. This is a change on purpose implemented on bug 578614.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Blocks: 578614

Updated

7 years ago
Summary: Installed skin/theme being used, despite being version incompatible. As a result, incorrect menu shown for right-click-on-tab. → Installed skin/theme being used, despite being version incompatible. As a result, incorrect menu shown when right-clicking on empty space on tab bar.
You need to log in before you can comment on or make changes to this bug.