tab context menu should not appear when right-clicking new tab button or the space to its right

VERIFIED FIXED in Firefox 4.0b2

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: fryn, Assigned: fryn)

Tracking

Trunk
Firefox 4.0b2
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 457268 [details] [diff] [review]
patch v1 (show toolbar context menu instead)

Actual Results:

When right-clicking the (non-overflow) new tab button or the space to its right, the tab context menu currently appears.
This is misleading, since most of the actions in the tab context menu then apply to the selected tab, which is neither the new tab button nor empty space.

Expected Results:

The toolbar context menu should appear for easy customization.
(Even having nothing appear would be acceptable.)
(Assignee)

Updated

7 years ago
Attachment #457268 - Flags: review?(dao)

Updated

7 years ago
Attachment #457268 - Flags: review?(dao) → review+
http://hg.mozilla.org/mozilla-central/rev/95c013f6c962
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b2
Verified with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre

Can we get an automated test for that change?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
(Assignee)

Comment 3

7 years ago
(In reply to comment #2)
> Can we get an automated test for that change?

When I have time, I'll put one together after bug 576345 gets fixed too.

Comment 4

7 years ago
Please rethink this one. No context at all is a bad idea. There are some commands that apply to all tabs like 'Close All Tabs', 'Reload All Tabs', 'Save All Tabs' and 'Bookmark All Tabs'.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Updated

7 years ago
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
If you wanna see that addressed please file a new bug.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Duplicate of this bug: 289270

Comment 7

7 years ago
(In reply to comment #5)
> If you wanna see that addressed please file a new bug.

Fair enough! Filed Bug 581646
This really should have gotten ui-review...
Depends on: 581646
(Assignee)

Updated

7 years ago
No longer depends on: 581646
Depends on: 604055
You need to log in before you can comment on or make changes to this bug.