Closed Bug 604351 Opened 9 years ago Closed 9 years ago

Software keyboard on Android doesn't pop up when focus is in an input field.

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ioana.chiorean, Assigned: vingtetun)

Details

(Whiteboard: [VKB])

Attachments

(1 file)

Build Identifier: Mozilla/5.0 (Android; Linux armv7l; en-US; rv:2.0b8pre)
Gecko/20101012 Firefox/4.0b8pre Fennec/4.0b2pre 

Device Motorola Droid 2

Steps to reproduce:
1. close the hardware keyboard
2. place the device in portrait mode
3. go to url : http://www.google.com
4. click in the text box to bring up the VKB
5. bring up the left panel
6. close the panel
7. click in the text box to bring up the VKB once more

Expected result:
- The VKB appears

Actual result:
- The VKB doesn't pop up

Note: 
- it's a regression for Bug 580269; Bug 581535
Seems exactly like a dupe of bug 601805
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601805
I don't think those are duplicate
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attached patch PatchSplinter Review
The problem is because the mouse events are not dispatched if the field is already focused by the form helper the VKB won't come up
Attachment #483150 - Flags: review?(mark.finkle)
Comment on attachment 483150 [details] [diff] [review]
Patch

Is this something we should fix in platform too? I am tempted to put a "// HACK" in the comment.
Attachment #483150 - Flags: review?(mark.finkle) → review+
Whiteboard: [VKB]
http://hg.mozilla.org/mobile-browser/rev/9e11da194db1
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Love the "hack" usage. verified FIXED on builds:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101015 Namoroka/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.