"Server Name" field in server settings should remove whitespace

RESOLVED DUPLICATE of bug 327812

Status

Thunderbird
Account Manager
--
minor
RESOLVED DUPLICATE of bug 327812
8 years ago
6 years ago

People

(Reporter: Ryan Jendoubi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: 

I made a mistake: I pasted in a server name copied from my university's email help pages, and didn't notice I'd left a whitespace character at the end of the server name.

I can't think of any purpose served by preserving whitespace at the beginning / end of server names. This should be trimmed on dialogue close, or at least when Tbird attempts to use the name to connect to the server.

Reproducible: Always

Steps to Reproduce:
1. Put a white space character at the end of an IMAP Server Name in Server Settings.
Actual Results:  
Error dialogue:"Failed to connect to server example.server.com ." (note whitespace preserved at end of server name. This is fairly easy to miss in the standard Tbird dialogue font)

Expected Results:  
Whitespace trimmed and correct server found.
What version of Thunderbird  are you using ?
(Reporter)

Comment 2

8 years ago
Ah, apologies, I see I'm only running 3.0.8. I think I downgraded at some point, 3.1 gave me some problems on Linux.

I take it this has been addressed in a more up to date version. I should've checked that first, sorry for timewasting.
(In reply to comment #2)
> Ah, apologies, I see I'm only running 3.0.8. I think I downgraded at some
> point, 3.1 gave me some problems on Linux.
> 
> I take it this has been addressed in a more up to date version. I should've
> checked that first, sorry for timewasting.

so you doubled checked in a recent build right ?
(Reporter)

Comment 4

7 years ago
Have just checked, this problem still exists in Thunderbird 5.

The only difference now that the notification of failure to connect is a system notification message showing the Account Name rather than the server name, the source of the problem is even more obscure.

Comment 5

7 years ago
Will be done in bug 80855.
Assignee: nobody → acelists
Depends on: 80855
OS: Linux → All
Hardware: x86 → All
Version: unspecified → Trunk

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Duplicate of this bug: 360985

Updated

6 years ago
No longer depends on: 80855

Updated

6 years ago
Depends on: 80855

Updated

6 years ago
Depends on: 327812

Comment 7

6 years ago
Actually this is covered by 327812 comment 0. So it will be fixed there.
Assignee: acelists → nobody
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327812

Updated

6 years ago
No longer depends on: 327812
You need to log in before you can comment on or make changes to this bug.