Closed Bug 604475 Opened 10 years ago Closed 5 years ago

remove wrappedObject JSClass hook

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 604523

People

(Reporter: gal, Assigned: gal)

References

Details

Attachments

(1 file)

No longer used by XPConnect.
Attached patch patchSplinter Review
Assignee: general → gal
Some places where we used use the wrappedObject we don't use the proxy unwrapped object. I have to look over those places with blake.
Blocks: 604516
wrappedObject was removed in https://hg.mozilla.org/mozilla-central/rev/ab80a372cfe1 (bug 604523)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604523
You need to log in before you can comment on or make changes to this bug.