Closed Bug 604752 Opened 9 years ago Closed 9 years ago

Nightly builds burning after removal of unwrap_full_update.sh

Categories

(SeaMonkey :: Release Engineering, defect, blocker)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: Callek)

References

Details

Our buildbot needs the patch from bug 327076 attachment 473582 [details] [diff] [review], so that we use the .pl version of that file.

This probably has to be applied to trunk and probably also to the 2.0 branch, since the removal has approval1.9.1.15+ too.
[seabld@cb-seamonkey-linuxmaster-01 buildbotcustom]$ sudo hg pull -u
pulling from http://hg.mozilla.org/build/buildbotcustom
searching for changes
adding changesets
adding manifests
adding file changes
added 103 changesets with 157 changes to 31 files
merging misc.py
6 files updated, 1 files merged, 0 files removed, 0 files unresolved

[seabld@cb-seamonkey-linuxmaster-01 buildbotcustom]$ cd /builds/master && buildbot checkconfig
Config file is good!
[seabld@cb-seamonkey-linuxmaster-01 master]$ buildbot reconfig .
sending SIGHUP to process 1871
Never saw reconfiguration finish.

Did it again and got output that overflowed my terminal, but ending with:

2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=OS X 10.5 comm-central-trun
k debug test mochitests-2/5 slave=cb-sea-miniosx01>
2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=OS X 10.5 comm-central-trun
k debug test mochitests-2/5 slave=cb-sea-miniosx02>
2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=OS X 10.5 comm-central-trun
k debug test mochitests-2/5 slave=cb-sea-miniosx03>
2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=OS X 10.5 comm-central-trun
k debug test mochitests-2/5 slave=cb-sea-miniosx04>
2010/10/15 19:02 PDT [-] updating builder Linux comm-central-trunk debug test mochitest-other:
factory changed
2010/10/15 19:02 PDT [-] consumeTheSoulOfYourPredecessor: <Builder 'Linux comm-central-trunk de
bug test mochitest-other' at 416505164> feeding upon <Builder 'Linux comm-central-trunk debug t
est mochitest-other' at 276583500>
2010/10/15 19:02 PDT [-]  stealing 0 buildrequests
2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=Linux comm-central-trunk de
bug test mochitest-other slave=cb-seamonkey-linux-01>
2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=Linux comm-central-trunk de
bug test mochitest-other slave=cb-seamonkey-linux-02>
2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=Linux comm-central-trunk de
bug test mochitest-other slave=cb-sea-linux-tbox>
2010/10/15 19:02 PDT [-]  stealing buildslave <SlaveBuilder builder=Linux comm-central-trunk de
bug test mochitest-other slave=cn-sea-qm-centos5-01>
2010/10/15 19:02 PDT [-] updating builder tag: factory changed
Never saw reconfiguration finish.


========================

I'm retriggering all red nightlies, even though it is late in the day. This *should* be fixed. [hoping no other errors come from this, as its been a long while since I did a reconfig]
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Ok, after linux64 failing I checked the system again, and I am confused as to what I am doing wrong... Reassigning to KaiRo and closing SeaMonkey tree too.


[seabld@cb-seamonkey-linuxmaster-01 buildbotcustom]$ grep "unwrap_full_update" process/factory
.py
                                    '/tools/update-packaging/unwrap_full_update.sh ' +
                                    '/tools/update-packaging/unwrap_full_update.sh ' +
[seabld@cb-seamonkey-linuxmaster-01 buildbotcustom]$ sudo hg pull -u r && build
pulling from http://hg.mozilla.org/build/buildbotcustom
searching for changes
no changes found
[seabld@cb-seamonkey-linuxmaster-01 buildbotcustom]$ hg ident
Not trusting file /tools/buildbotcustom/buildbotcustom/.hg/hgrc from untrusted user root, group
 root
Not trusting file /tools/buildbotcustom/buildbotcustom/.hg/hgrc from untrusted user root, group
 root
.hgtags@666f6c60d3e3, line 93: tag 'FIREFOX_3_6_9_BUILD1' refers to unknown node
.hgtags@666f6c60d3e3, line 94: tag 'FIREFOX_3_6_9_RELEASE' refers to unknown node
1351003e0957
[seabld@cb-seamonkey-linuxmaster-01 buildbotcustom]$ sudo hg update
0 files updated, 0 files merged, 0 files removed, 0 files unresolved
[seabld@cb-seamonkey-linuxmaster-01 buildbotcustom]$ sudo hg ident
.hgtags@666f6c60d3e3, line 93: tag 'FIREFOX_3_6_9_BUILD1' refers to unknown node
.hgtags@666f6c60d3e3, line 94: tag 'FIREFOX_3_6_9_RELEASE' refers to unknown node
1351003e0957
Assignee: bugspam.Callek → kairo
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ahh my problem here was that the buildbotcustom change that is required never landed on buildbotcustom |default| branch, and we are using the default branch on our master.

This is because our master is still not using the buildbot-0.8.0 code [aiui], I got r=coop via IRC to land the patch to the buildbotcustom |default| and I'm updating the master now. Note: I am not going to kill any builds or manually trigger any nightlies tonight, so leaving open until it is confirmed this works.
Assignee: kairo → bugspam.Callek
...aaaand all 4 platforms have a nightly now... resolved.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
I can haz openz treez?
You need to log in before you can comment on or make changes to this bug.