Inline image pasted from clipboard fails to send

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: xoc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

Images pasted from the clipboard inline into HTML format message text fails to send or even store in Sent Items when textfile signature included.

Reproducible: Always

Steps to Reproduce:
1. Create a POP account with composition set to HTML and attach
2. Create a textfile signature, and check "Attach the signature from a file..."
3. Copy image into clipboard.
4. Create new message, ensure from account is correct, fill out To: and Subject:
5. Paste image into body of message and send.
Actual Results:  
Message in "Sent Items" and recipient's Inbox does not display the pasted image.

Expected Results:  
Message should be WYSIWYG.

I confirmed that un-checking the "Attach signature from file..." option allows pasted images to be sent as expected.
Is this fixed in 3.1.5 that is coming out nowish (ie today or tomorrow depending on you time zone).
could this be a duplicate of bug 531437 ?

Comment 3

7 years ago
Same here on Linux Mint Julia (11) x64 and Thunderbird 6.0 (channel version)

1) Copy some image to the clipboard
2) Compose a mail in HTML mode (ok have to say I never do, but for a special reason I did this rare exception today)
3) Paste the image into the mail, write an A before and after
4) Send.
5) The recipient recieves two A's and nothing in between. Looking at the message source, there's absolutely nothing there.
6) Point 5) goes for the message stored in the Sent folder too, not surprisingly.
xoc, arno, you still see this problem on TB13?
Summary: Pasted of image fails to send → Inline image pasted from clipboard fails to send
wfm on TB13/WinXP.
Following steps exactly, inline image from clipboard with or without surrounding text gets sent as expected.

Feel free to reopen if this problem still occurs for you on TB13 and above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.