crash [@ nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) | nsContentUtils::CanCallerAccess(nsPIDOMWindow*) ] [@ _purecall | nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) | nsContentUtils::CanCallerAccess(nsPIDOMWindow*) ]

RESOLVED DUPLICATE of bug 612383

Status

()

Core
DOM
--
critical
RESOLVED DUPLICATE of bug 612383
8 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
All
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(crash signature)

(Reporter)

Description

8 years ago
Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101017
Firefox/4.0b8pre

It is a new crash signature. Crashes first appeared in b8pre/20101013 build.
It happens on Windows and Mac OS X.
Because of multiple signatures, it is hard to determine its rank as a top crasher.

Signature	nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) | nsContentUtils::CanCallerAccess(nsPIDOMWindow*)
UUID	fb0c2e2b-f8c7-434e-b1ac-0d6de2101017
Time 	2010-10-17 05:57:40.2669
Uptime	13706
Install Age	77482 seconds (21.5 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101016041245
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 30 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x15
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 68c0

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsCOMPtr_base::assign_from_qi 	obj-firefox/xpcom/build/nsCOMPtr.cpp:96
1 	xul.dll 	nsContentUtils::CanCallerAccess 	content/base/src/nsContentUtils.cpp:1344
2 	xul.dll 	nsDOMConstructor::Create 	
3 	xul.dll 	ResolvePrototype 	dom/base/nsDOMClassInfo.cpp:6073
4 	mozjs.dll 	JS_AlreadyHasOwnPropertyById 	js/src/jsapi.cpp:3313
5 	xul.dll 	nsDOMClassInfo::PostCreatePrototype 	dom/base/nsDOMClassInfo.cpp:4707
6 	mozjs.dll 	mozjs.dll@0x739f 

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2593c8c8af8b&tochange=f6e81dd5a125

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&date=2010-10-17%2007%3A00%3A00&signature=nsCOMPtr_base%3A%3Aassign_from_qi%28nsQueryInterface%2C%20nsID%20const%26%29%20|%20nsContentUtils%3A%3ACanCallerAccess%28nsPIDOMWindow*%29&version=Firefox%3A4.0b8pre
blocking2.0: --- → ?
(Reporter)

Comment 1

8 years ago
It can be a dupe of bug 604589.
Are you sure the regression range is correct?
(This sounds like a compartments related bug.)
(Reporter)

Comment 3

8 years ago
> Are you sure the regression range is correct?
Go to the report link of comment 0 and then switch to the Graph tab.
The first appearance of this crash signature is in b8pre/20101013 build.
That does not necessarily mean that it is due to a change in this build. It could have been introduced before and it triggered in this build for an external reason (update of an extension...)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604449
blocking2.0: ? → beta7+
(Reporter)

Updated

8 years ago
Duplicate of this bug: 607271
(Reporter)

Updated

8 years ago
Duplicate of bug: 612383
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) | nsContentUtils::CanCallerAccess(nsPIDOMWindow*) ] [@ _purecall | nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) | nsContentUtils::CanCallerAccess(nsPIDOMWindow*) ]
You need to log in before you can comment on or make changes to this bug.