Closed Bug 605100 Opened 9 years ago Closed 9 years ago

Add services & sync folders to mobile/build.mk

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
All
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: ahoza, Assigned: fabrice)

Details

Attachments

(2 files)

Device: Nokia N900
BuildID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre)Gecko/20101018
Firefox/4.0b8pre Fennec /4.0b2pre 

Device: HTC Desire
BuildID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101018
Firefox/4.0b8pre Fennec /4.0b2pre 

Steps reproduce:

1. Open Fennec.
2. Open Options->Preferences and enter information in sync fields.
3. Tap "Connect"

Expected results:
Device is connected to sync server.

Actual results:
Nothing happens.
Is this for a clean profile that has never been synced before?
Is the 'connect' button disabled?
The button doesn't look to be disabled, but it acts as if it were.
I've tried with an account that I've successfully synced in the previous week.
I've also created a new sync account and tried to sync with it. Couldn't connect either. 
As for Fennec, on Nokia N900, I've deleted profile folder before installing the latest build.
Can you get a screenshot? We recently landed code that will make the Sync UI look like it is connecting when Fennec starts - _if_ the user has already filled in the account name, password and sync key previously.

We do this because Sync will be auto-connecting in a few seconds anyway.

You might have found a regression from that - or you are just seeing the correct behavior (if the button is disabled)
Attached image Screenshot
Did you type the account name, password, and sync key? Or did they auto-fill?
tracking-fennec: --- → ?
I typed in the account name, password and sync key and the connect button did nothing.
(In reply to comment #6)
> I typed in the account name, password and sync key and the connect button did
> nothing.

Doesn't seem to be a regression from bug 602077.
I used an email address instead of an account name (non email address), password, and sync from a clean install (no profile) on Droid 2, and the connect button did nothing.

Trying to go to about:sync-log gives error message of :"The URL is not valid and cannot be loaded."
(In reply to comment #8)
> Trying to go to about:sync-log gives error message of :"The URL is not valid
> and cannot be loaded."

Sync no longer writes the log by default. You can change that by creating the services.sync.log.appender.debugLog preference as a Boolean and set it to true. You should see errors in the error console, too, though.
In error console:
Error: Weave is not defined  Source File: chrome://browser/content/sync.js Line: 75
(In reply to comment #9)
> Sync no longer writes the log by default. You can change that by creating the
> services.sync.log.appender.debugLog preference as a Boolean and set it to true.

Ugh, sorry, this should be services.sync.log.appender.debugLog.enabled = true (forgot the .enabled)
I tried to Sync Now using the Tools menu item on Mac on the latest nightly, then I went to about:sync-log, and there's no update since the 15th. Shift reloading after Sync Now doesn't change this.
blocking2.0: --- → ?
After talking to tchung, I rescind my blocking request. I was under the impression the sync'ing process was not working, instead of the logging part, which is not a blocking problem.
blocking2.0: ? → ---
(In reply to comment #13)
> After talking to tchung, I rescind my blocking request. I was under the
> impression the sync'ing process was not working, instead of the logging part,
> which is not a blocking problem.

As I've noted in comment 9, Sync will no longer log to disk by default (for obvious performance reasons), but as noted in comment 11 you can flip it back on using the services.sync.log.appender.debugLog.enabled pref.
can we get this approved to block beta 2 please?
Assignee: nobody → fabrice
tracking-fennec: ? → 2.0b2+
We found this bug is a regression from bug 586867, which needed some code to be added to mobile/build.mk
Attached patch patchSplinter Review
Seems to work for me now
Attachment #484100 - Flags: review?(fabrice)
Comment on attachment 484100 [details] [diff] [review]
patch

Works here for me also.
Attachment #484100 - Flags: review?(fabrice) → review+
Summary: "Connect" button in Sync section not working. → Add services & sync folders to mobile/build.mk
pushed:
http://hg.mozilla.org/mobile-browser/rev/55edc5093be0
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified as fixed on BuildID: Mozilla /5.0 (Maemo;Linux rmv7l;rv:2.0b8pre)Gecko/20101019 Firefox/4.0b8pre Fennec /4.0b2pre
Status: RESOLVED → VERIFIED
(In reply to comment #20)
> Verified as fixed on BuildID: Mozilla /5.0 (Maemo;Linux
> rmv7l;rv:2.0b8pre)Gecko/20101019 Firefox/4.0b8pre Fennec /4.0b2pre

Adriana, please also verify this is also fixed on Android before marking RESOLVED FIXED.
(In reply to comment #21)
> (In reply to comment #20)
> > Verified as fixed on BuildID: Mozilla /5.0 (Maemo;Linux
> > rmv7l;rv:2.0b8pre)Gecko/20101019 Firefox/4.0b8pre Fennec /4.0b2pre
> 
> Adriana, please also verify this is also fixed on Android before marking
> RESOLVED FIXED.

I mean VERIFIED Fixed
Verified as fixed on HTC Desire A8181, Motorola Droid 2 with buildID:
Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre)Gecko/20101019 Firefox/4.0b8pre Fennec /4.0b2pre
You need to log in before you can comment on or make changes to this bug.