Closed Bug 605121 Opened 9 years ago Closed 9 years ago

Panning is not working when having 4 items in the list (landscape view)

Categories

(Firefox for Android Graveyard :: General, defect, minor)

ARM
Android
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 4.0

People

(Reporter: andreea.pod, Assigned: vingtetun)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101014 Firefox/4.0b8pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101017 Firefox/4.0b8pre Fennec /4.0b2pre 

Last item in synced bookmarks is not visible and panning doesn't work.

Reproducible: Always

Steps to Reproduce:
Prerequisites:
Configure FF desktop with a sync account.
Have 4 sites bookmarked in Bookmark Menu (remove Mozilla Firefox from this folder, or bookmark only 3 sites)
 
1.Open Fennec > Preferences
2.Connect to Sync account mentioned in Prerequisites section (be sure bookmarks were sync'd)
3.Open awesome bar, Bookmarks > Desktop Bookmarks > Bookmarks Menu
Actual Results:  
if there are exactly 4 bookmarks you can't see last bookmark and you can't either pan the list to see it.

Expected Results:  
you can pan the list and see all bookmarks

Device: Motorola Droid 2
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Other → Android
Hardware: Other → ARM
Attached image screenshot
Attached patch PatchSplinter Review
We need to look at the originalTarget of the event in order to get richlistbox nested inside a binding.
Assignee: nobody → 21
Attachment #522980 - Flags: review?(mark.finkle)
Attachment #522980 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/e0842af24ca7
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Due to bug 656605 I cannot verify this bug.
Target Milestone: --- → Firefox 4.0
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110608 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.