Closed Bug 605354 Opened 14 years ago Closed 14 years ago

opening incredimail message causes future composed messages to force white text on white background

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 525359

People

(Reporter: shinji, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

Attached to this bug report is a message composed in Incredimail.  We actually received this email and it caused a really weird bug to appear.  Once the message is viewed we can't create any messages from then on out without the text being forced white with the background white as well.  The text color and background color are completely ignored and it doesn't matter what you set it to.  It did take me a while to determine that was happening.  Originally it appeared that the message body wasn't accepting any input until I realized that I could select the text still and drag it to see that what I was typing was actually still getting there.  This is the only email causing the issue.  We can skip over it and all is well until the message is viewed.  The version being attached is censored removing personal information (the sender and rcpt name and email address).  It still reproduces with this version.  I also reproduced it on a Windows 7 x64 machine running the same version.

Reproducible: Always

Steps to Reproduce:
1. Insert the attached email message into thunderbird (drag and drop, doesn't matter where)
2. Restart thunderbird
3. Verify you can create message normally
4. View attached email message
5. Note the change in behavior when trying to reply to any message or create a new one
Actual Results:  
Text and background color are forced white making the appearance that nothing is being typed.  Also makes all content from the message being replied to white as well.

Expected Results:  
Message creation should continue to work normally after step 4.

I reproduced it on my laptop after a little work.  Here are the primary bits for the configuration.

1 email account configured with email received.
no other accounts
On the original machine we had no plugins installed
Attached file Reproducable test case
This is the message I could reproduce with.
I forgot to mention that if for some reason you are unable to reproduce this I'll zip up my test profile folder for you.
(In reply to comment #1)
> Created attachment 484203 [details]
> Reproducable test case
> 
> This is the message I could reproduce with.

I can't with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.11) Gecko/20101013 Thunderbird/3.1.5 . 

Anything in Tools -> Error console when this happens ?

Do you also see the issue when you run Thunderbird in -safe-mode (http://support.mozillamessaging.com/en-US/kb/Safe+Mode) ?
I get some of these in the there when the issue occurs.

Warning: Expected ',' or '{' but found '*'.  Ruleset ignored due to bad selector.
Source File: about:blank
Line: 1

There are no filter rules set so that can't be from that.  I also tried it in safemode and same result.
should be a dup of bug 525359, no?
I concur.  I didn't notice the other report but it may very well be a dup of that.  If you want to mark it as such then go ahead.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.