Switch to tab not working if it's not in the active group.

RESOLVED WORKSFORME

Status

defect
P2
normal
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: shaver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WFM?])

Attachments

(1 attachment)

(I'm on vacation, apologies for not filing these all separately or doing more than cursory dup-checking.  And I have the slimmest of borrowed wifi so there aren't screenshots to upload yet.)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre

* Missing tabs: I have 14 tabs listed in the tab dropdown for my only open window, but 18 in the aero peek list.  Picking one of the orphaned tabs from the aero peek list brings it into my current window.

* Typing "gmail" in the URL bar offers to switch to the open (orphaned) tab, but picking that entry doesn't do anything but dismiss the awesomebar popup.  The "Switch to tab:" prefix remains to the left of the URL.

* Pressing Ctrl-E -- which might be what got me into this mess, because I didn't intend to use panorama at all -- gives me a blankish grey screen, with a strange circle in the top left, a non-responsive "manage your tabs" button on the right, and no tabs in it.  I can draw groups, but not drag them.  I *thought* there was no way out other than restarting, but picking a tab from the aero peek list works!
Hope this works -- sorry it's scaled down 50%, trying to make the upload work in finite time.
No idea how that didn't time out, but I'll take it!
Of the three items mentioned in comment 0, items 1 and 3 are most likely bug 598600. Item number two is fresh; changing this bug to be about that. To repeat:

* Typing "gmail" in the URL bar offers to switch to the open (orphaned) tab,
but picking that entry doesn't do anything but dismiss the awesomebar popup. 
The "Switch to tab:" prefix remains to the left of the URL.

I suspect this may happen particularly after the browser starts but before you've entered Panorama for the first time. It may be related to bug 589324.
Blocks: 598154
Priority: -- → P2
Summary: multiple panorama bugs → Switch to tab not working if it's not in the active group.
The switch-to-tab feature has a few dependencies over in bug 480350.  I'm not even sure if this is a dupe of bug 558626 either since I don't think that mentions TabCandy interaction.

Comment 5

8 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 6

8 years ago
bugspam (removing b9)
No longer blocks: 598154
This works for me now. Shaver et al, can you still reproduce this?
Whiteboard: [WFM?]

Comment 8

8 years ago
bugspam. Moving b10 to b11
Blocks: 627096

Comment 9

8 years ago
bugspam. Removing b10
No longer blocks: 608028

Comment 10

8 years ago
This is WFM also. If anyone still has problems, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.