Closed Bug 605806 Opened 11 years ago Closed 11 years ago

black around caption buttons in aero basic theme

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla2.0b7
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: bugmozz, Assigned: Felipe)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image screenshot
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre ID:20101020042802

nothing to do with HW acceleration.
happen with Windows 7 Basic Theme. (fine with Aero Theme)
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre ID:20101020042802
Assignee: nobody → felipc
Status: NEW → ASSIGNED
Does the XP-one happen without a Persona like the Win7-one?
yes
maybe bug 605815 is related - the shift-to-the-right when you right-click, is the distance as the black box
blocking2.0: --- → ?
blocking2.0: ? → betaN+
Attached patch PatchSplinter Review
I forgot that these -moz-appearance styles are used for non-glass themes
Attachment #484948 - Flags: review?(jmathies)
Duplicate of this bug: 606131
Comment on attachment 484948 [details] [diff] [review]
Patch

that fixes it. thanks!
Attachment #484948 - Flags: review?(jmathies) → review+
Summary: black around caption buttons → black around caption buttons in aero basic theme
http://hg.mozilla.org/mozilla-central/rev/8ae7d48b0ad7
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
with Hourly (20101022110028 2842d671052f)

fix confirmed.
thank you.
Duplicate of this bug: 606636
Duplicate of this bug: 606903
Target Milestone: mozilla2.0b8 → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.