Bulleted lists do not align correctly with images

VERIFIED DUPLICATE of bug 57882

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 57882
18 years ago
16 years ago

People

(Reporter: wenn0029, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
mozilla1.2alpha
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: {bae:20011129], URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001116
BuildID:    2000111604

When an image is to the right of a bulleted list, the list will loose it's
indentation and the bullets will go over the image.  This may be related to bug
59051?  See page http://www.visi.com/~batcave/mozilla_bug.html for a detailed
description.

Reproducible: Always
Steps to Reproduce:
See page http://www.visi.com/~batcave/mozilla_bug.html for a detailed description.

Updated

18 years ago
Keywords: makingtest

Comment 1

18 years ago
Created attachment 19457 [details]
minimum testcase

Comment 2

18 years ago
Created minimum testcase.
Not ENTIRELY sure this is a bug, as (I *think*) the align="left" of an image is
inside the padding section on the format, and the list markers go in the padding
section. Someone with more knowledge of the rendering rules on HTML4?
Keywords: makingtest → testcase

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
confirmed mozilla build:2000111704 Win98.
IE5.5 SP1 renders this almost identically, except for the position of the 
bullets. This could be an HTML "quirk", as you say.The padding for the list 
could overlap the padding for the image, (depending on the order they're 
rendered?)
I had endless trouble with bulletted lists and CSS positioning (IE5 adds a 
larger margin than mozilla, amongst other things). Try messing about with CSS 
padding,border and margin attributes if this is a serious problem for you.
Please triage.
Assignee: clayton → harishd

Comment 5

18 years ago
Sounds like a layout bug. Giving bug to buster.
Assignee: harishd → buster

Comment 6

17 years ago
*** Bug 70921 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Moving to m1.0 and reassigning to attinasi.
Assignee: buster → attinasi
Target Milestone: --- → mozilla1.0

Comment 8

17 years ago
Created attachment 45190 [details]
Testcase #2

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Comment 9

17 years ago
http://www.visi.com/~batcave/mozilla_bug.html: file not found
looking at the attached test case I am not clear why the list aligns further to 
the right, I would have expected the list to align as it would normally, or 
would align outside of the image area.

David or Ian: any ideas as to whythis is laying out the way it does?
Whiteboard: {bae:20011129]
... because -moz-float-edge is broken or not working quite as intended.  See the
various bugs with moz-float-edge in the summary, and also bug 802.

*** This bug has been marked as a duplicate of 57882 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
V
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.