Closed Bug 606183 Opened 11 years ago Closed 11 years ago

CtrlTab previews works even when disabled

Categories

(Firefox :: Tabbed Browser, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 544833

People

(Reporter: d4v30h, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

The Ctrl+Shift+Tab shortcut to tab previews and searching works when a popup box shows on Gmail. (This is most easily done by using the "steps to reproduce" however I believe it works on all popup dialogs of the same type.)
I didn't even know this feature existed before I was trying to switch to a previous tab and then it popped up.

Reproducible: Always

Steps to Reproduce:
1. Open Gmail.
2. Under the labels on the left hand side, select "Create new label"
3. After the popup box shows up asking for a label name, Ctrl+Shift+Tab previews now works.
Actual Results:  
Ctrl+Shift+Tab previews shows

Expected Results:  
Switches to previous tab

I checked my about:config, browser.ctrlTab.previews;false
I had to search Google to find out about the feature in the first place, and to find out what the config setting would be.
You will have to reset 'browser.allTabs.previews' to disable this feature.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> You will have to reset 'browser.allTabs.previews' to disable this feature.

'browser.allTabs.previews' hasn't been changed from its default value 'false'.
The same applies to browser.ctrlTab.previews.
So I can't reset it if it's already at its default value?
I have checked it on multiple machines as well, and it still happens.
Hm, now I can at least see it with browser.ctrlTab.previews enabled. Once I disable this prev the all tabs preview is not enabled. But when both preferences are set to false none of the both ui will appear. Have you tested with a fresh profile?

Dao, has there been changed something lately?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
I just experienced this same bug.  The following is a list of steps to repeat it and a list of steps I have taken in attempt to resolve it.

System information:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Note:  browser.allTabs.previews is set to to false during the following series of events. 
1) Go to twitter.com.
2) Enter the search textbox, the direct message textbox, or possibly any text box (only tested the first two) on the New Twitter interface.
3) Press CTRL-SHIFT-TAB twice.
4) The show all tabs screen pops up, which you would get with browser.allTabs.previews set to true and if you clicked the show all tabs.


I cannot seem to repeat this anywhere else - I haven't tried GMail as the original poster suggested.

Steps attempted to resolve:

1) Disabled all add-ons.  Still occurred after.
2) Changed browser.allTabs.previews to true.  Changed browser.allTabs.previews to false.  Still occurred after (and of course occurred when previews was set true).
3) Moved old profile, tried a fresh profile.  Still occurred in the fresh profile.
4) Disabled all extensions.  Still occurred after.
5) Checked to make sure everything was disabled, that browser.allTabs.previews was false, that nothing should be triggering it, and that I was on a new profile ... and, still occurs.
6) Gave up and stopped going to Twitter.com.  Stopped occurring.  (funny that).

Thanks.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 544833
You need to log in before you can comment on or make changes to this bug.