Closed Bug 544833 Opened 12 years ago Closed 11 years ago

Tab preview feature activates even when turned OFF

Categories

(Firefox :: Tabbed Browser, defect)

3.6 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 4.0b8
Tracking Status
blocking2.0 --- -

People

(Reporter: ondras, Assigned: heycam)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

Under certain circumstances, the "tab previews" are activated by pressing ctrl+shift+tab, even when this features is turned off in about:config.

In order to reproduce this, the page must stopPropagation of "keypress" event attached on "document".

Reproducible: Always

Steps to Reproduce:
1. Make sure tab previews are disabled
2. Open http://bespin.cz/~ondras/ff36/ in Firefox 3.6
3. Hit ctrl+shift+tab
4. See the tab previews
Actual Results:  
Tab previews are shown.

Expected Results:  
When tab previews are disabled, ctrl+shift+tab should switch to previous opened tab.
Version: unspecified → 3.6 Branch
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100205 Namoroka/3.6.2pre
Component: General → Tabbed Browser
QA Contact: general → tabbed.browser
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: in-testsuite?
OS: Windows XP → All
Hardware: x86 → All
Duplicate of this bug: 566741
I have noticed in the URL linked in this bug (as well as http://mail.aol.com where I first noticed the bug) that not only do tab previews show up on pressing Ctrl-Shift-Tab, but the focus jumps to the location bar on Ctrl-Tab.
Duplicate of this bug: 612521
You can also reproduce this by focusing the identity button in the location bar
(click location bar, then press Shift+Tab) and then pressing Ctrl+Shift+Tab or
Ctrl+Tab.
Here's a patch that makes the Show All Tabs thing not pop up when pressing
Ctrl+Shift+Tab in these circumstances.

A couple of questions:

1. Is it OK that I fold in the whitespace fixes in this patch (removing
   CRs), or is it preferable to have that separate?

2. How do I write a test for this?  (So far I've only had experience with
   reftests.)
Attachment #493615 - Flags: feedback?(dao)
Comment on attachment 493615 [details] [diff] [review]
Prevent Ctrl+Shift+Tab from triggering Show All Tabs if browser.ctrlTab.previews is false.

Thanks!
Attachment #493615 - Flags: feedback?(dao) → review+
Thanks for the r+.  I take it I don't need to write a test, then. :-)
Assignee: nobody → cam
Keywords: checkin-needed
This needs approval before it can land on mozilla-central.
Keywords: checkin-needed
blocking2.0: --- → ?
Duplicate of this bug: 606183
Not a regression, so not a blocker. Will take the patch though.
blocking2.0: ? → -
Attachment #493615 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/a8c06e21635d
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
You need to log in before you can comment on or make changes to this bug.