Enhance UI for Search Engines

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: ahoza, Assigned: wesj)

Tracking

Trunk
ARM
Maemo
Bug Flags:
in-testsuite ?
in-litmus +

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 485240 [details]
No Search Engine Enabled screenshot

Device: Nokia N900
BuildID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre)Gecko/20101021 Firefox/4.0b8pre Fennec /4.0b2pre 


Steps to reproduce:

Scenario 1:

1. Open Fennec.
2. Go to Options->Add-ons
3. Disable all search engines.
4. Tap awesome bar and then "Search Engine" icon

Expected results:
User should not be allowed to disable all default search engines or
"No enabled search engines" should be displayed while in Awesome bar-> magnifier glass icon (see screenshot) or
"Search engine" button is disabled when no seaarch engines are enabled


Scenario 2:

1. Open Fennec.
2. Install 2-3 extra search engines (go to: addons.mozilla.org/en-US/mobile/, bugzilla.mozilla.com, cnn.com tap the site's favicon and choose "Add Search Engine")
3. Tap awesome bar and then magnifier glass icon.
4. Observe associated icon for each search engine

Expected results:
The icons should have the same size.

Actual results:
Default search engines icons are bigger (see screenshot)
 
Scenario 3:

1. Open Fennec.
2. Install one extra add-on.
3. Go to Options->Add-ons and disable Wikipedia search engine
4. Tap awesome bar and then magnifier glass icon.

Expected results:
Display should look good.

Actual results:
Separators are not aligned. (see screenshot)
(Reporter)

Comment 1

8 years ago
Created attachment 485242 [details]
Icons
(Reporter)

Comment 2

8 years ago
Created attachment 485243 [details]
Separators
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601852
(Assignee)

Updated

8 years ago
Assignee: nobody → wjohnston
(Assignee)

Comment 4

8 years ago
Whoops. Wrong bug. Sorry :(
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I thought we fixed the icon sizing in bug 606205 and we disable the the search
button if no engines are installed in bug 606056?
(Assignee)

Comment 6

8 years ago
I think we do too. All three situations work for me now.
Sold!
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
verified FIXED on build:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101025 Namoroka/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Flags: in-litmus? → in-litmus?(aaron.train)

Updated

8 years ago
Flags: in-litmus?(aaron.train) → in-litmus+
You need to log in before you can comment on or make changes to this bug.