Enable plugin hooks once WindowsDllInterceptor supports 64-bit

RESOLVED FIXED in mozilla8

Status

()

Core
Plug-ins
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jimm, Assigned: m_kato)

Tracking

(Blocks: 1 bug)

Trunk
mozilla8
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
http://mxr.mozilla.org/mozilla-central/source/modules/plugin/base/src/nsPluginNativeWindowWin.cpp#495

and

http://mxr.mozilla.org/mozilla-central/source/dom/plugins/PluginInstanceChild.cpp#1349
(Reporter)

Updated

7 years ago
Blocks: 471090
Depends on: 604302
(Reporter)

Comment 1

7 years ago
bah, sorry for the spam, that was the wrong bug #.
Blocks: 558448
No longer blocks: 471090
(Assignee)

Comment 2

6 years ago
Created attachment 528062 [details] [diff] [review]
fix
Assignee: nobody → m_kato
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Attachment #528062 - Attachment is patch: true
(Assignee)

Updated

6 years ago
Attachment #528062 - Flags: review?(benjamin)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 654110
Since I'm backed up on reviews and other priorities all this win64 stuff which I think is pretty low priority may have to wait 4-6 weeks.
Modifying blocking issues since this does not block work on the releng side but as to affect the product.

FTR this bug might start getting attention as we are aiming to release a Windows 64-bit version of Firefox sometime this year.
Blocks: 471090
No longer blocks: 558448
Attachment #528062 - Flags: review?(benjamin) → review+
(Assignee)

Comment 6

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/4c1c8236bac9
Hardware: x86 → x86_64
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/4c1c8236bac9
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
I have filed a make check test failures that I believe is related to the code in this bug.
Would you please be able to have a look? Thanks.

Bug 681238 - TEST-UNEXPECTED-FAIL | WindowsDllInterceptor | Failed to add hook
(Assignee)

Comment 9

6 years ago
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #8)
> I have filed a make check test failures that I believe is related to the
> code in this bug.
> Would you please be able to have a look? Thanks.
> 
> Bug 681238 - TEST-UNEXPECTED-FAIL | WindowsDllInterceptor | Failed to add
> hook

Get/SetWindowLongPtr hook works (I have checked it on debugger.)  Bug 681238 depends on hooked API.  GetVersionEx has complex MOV code on x64.
You need to log in before you can comment on or make changes to this bug.