Deleting mail fails until after switching folders. error nsIMsgDBView.doCommand FolderDisplayWidget_doCommand :: line 1762

RESOLVED INCOMPLETE

Status

Thunderbird
Folder and Message Lists
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Paul Collier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-05-01])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: 3.1.5

I have used Thunderbird for years, with one e-mail address. After adding a second address the problems started. If I get mail sent to my second address I cannot delete the ones I would like too. But, if I use the delete button, nothing happens, unless I switch from my first address then instantly back to my second address, then they delete one at a time without me doing anything. This happens everytime. I went into the "error-console" pasted a error that I found, it is pasted below. Please help... Thank you,,,

Reproducible: Always




Error: An error occurred executing the cmd_delete command: [Exception... "Component returned failure code: 0x80550008 [nsIMsgDBView.doCommand]"  nsresult: "0x80550008 (<unknown>)"  location: "JS frame :: chrome://messenger/content/folderDisplay.js :: FolderDisplayWidget_doCommand :: line 1762"  data: no]
Source File: chrome://global/content/globalOverlay.js
Line: 100
Imap or pop3 ?
Do you tried to change the delete options in the Account properties for your Account (if you use IMAP)

Comment 2

7 years ago
(In reply to comment #1)
> Imap or pop3 ?
> Do you tried to change the delete options in the Account properties for your
> Account (if you use IMAP)

Paul, do you still see this problem and can you reply for Matti's questions?
Does this happen also with thunderbird started in safe mode?


FWIW, I've seen this recently with trunk build. bienvenu wrote about my log, "delete really is happening on the server, and the issue has to do with removing the message from the view"
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Summary: Deleting mail → Deleting mail fails until after switching folders. error nsIMsgDBView.doCommand FolderDisplayWidget_doCommand :: line 1762
Whiteboard: [closeme 2011-05-01]
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

7 years ago
I have not responded to this due to cancer treatment. Still have same problem. I have a pop3 account. I used Thunderbird for years, with one account and no problems. I added a second account. In the second account when I "read" then click on "delete", the mail does not delete. But if I switch to the first account, then back to the secound account, all the e-mails that did not delete, go away, with me doing nothing. Trust you can be of help, Many thanks,, Paul
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.