Closed Bug 606485 Opened 9 years ago Closed 9 years ago

Alternate keyboard (SwiftKey) does not work correctly w/ Fennec

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0b3+)

RESOLVED DUPLICATE of bug 581596
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: ioana.chiorean, Assigned: crowderbt)

Details

(Whiteboard: [VKB])

Attachments

(1 file)

Build Identifier: Mozilla/5.0 (Android; Linux armv7l; en-US; rv:2.0b8pre)
Gecko/20101022 Firefox/4.0b8pre Fennec/4.0b2pre 

Device Motorola Droid 2

SwiftKey available on the android market or here:
http://www.appbrain.com/app/com.touchtype.swiftkey.trial

Steps to Reproduce:
1. Open Fennec w/ SwiftKey enabled
2. Tap awesome bar
3. Try to enter a URL, like touch.facebook.com.

Actual Results:  
Hitting the "." will type ". " (a dot and a space)

Expected Results:  
Should be able to use alternate keyboards w/ Fennec w/ correct keyboard
behavior.

Note: 2/10 time pressing . in the Swiftkey brought up a crash reporter for Swiftkey
I should state that instead of deleting it gives a ". "
tracking-fennec: --- → ?
Whiteboard: [VKB]
Assignee: nobody → crowderbt
tracking-fennec: ? → 2.0b3+
Swiftkey currently has no way of knowing that it shouldn't insert spaces.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581596
Attached image buttons missing
Steps to reproduce:
1. go to about:config
2. tap the search field : enter text 
3. delete the text or press x in the search bar
4. press ass new preference (ex: boolean)
sorry
wrong attachment
You need to log in before you can comment on or make changes to this bug.