Unable to add Sherlock search plugin

VERIFIED FIXED in Firefox 4.0b7

Status

()

Firefox
Search
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Mycroft Project (CC), Assigned: Gavin)

Tracking

({regression})

Trunk
Firefox 4.0b7
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Am unable to add any Sherlock search plugins recently - haven't checked with builds before and after but bug 599751 seems like the obvious candidate esp. as the error is:

_onLoad: Failed to init engine!
ReferenceError: valueEnd is not defined

Linked url gives example to try.
Ineed, valueEnd is used outside the block where it is declared - let makes that an error.
Blocks: 599751
blocking2.0: --- → beta8+
https://hg.mozilla.org/mozilla-central/rev/859ffcd7933a
Assignee: nobody → gavin.sharp
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
Created attachment 485663 [details] [diff] [review]
test

Comment 4

7 years ago
This bug was caused by not applying some of the whitespace changes :-(

To be specific, Serge had outdented the block in question (which was an else after return, so should never have been indented in the first place) which would have meant that let would have worked.
https://hg.mozilla.org/mozilla-central/rev/2797d4bc3f2d
Flags: in-testsuite+
(Reporter)

Comment 6

7 years ago
Confirm now works as expected again.
Thanks for catching this, Charles.
Marking as verified fixed then.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Target Milestone: Firefox 4.0b8 → Firefox 4.0b7
You need to log in before you can comment on or make changes to this bug.