Last Comment Bug 606934 - We don't register Thunderbird as the default .eml handler on linux
: We don't register Thunderbird as the default .eml handler on linux
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: OS Integration (show other bugs)
: Trunk
: All Linux
: -- normal with 1 vote (vote)
: Thunderbird 13.0
Assigned To: Hiroyuki Ikezoe (:hiro)
:
Mentors:
: 300393 693092 (view as bug list)
Depends on: 309708
Blocks: 726969
  Show dependency treegraph
 
Reported: 2010-10-25 05:32 PDT by Ludovic Hirlimann [:Usul]
Modified: 2012-02-23 00:37 PST (History)
9 users (show)
standard8: wanted‑thunderbird+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix for Linux (6.21 KB, patch)
2012-02-07 22:49 PST, Hiroyuki Ikezoe (:hiro)
mconley: review+
Details | Diff | Splinter Review
Revised patch (6.25 KB, patch)
2012-02-13 22:30 PST, Hiroyuki Ikezoe (:hiro)
hiikezoe: review+
Details | Diff | Splinter Review

Description Ludovic Hirlimann [:Usul] 2010-10-25 05:32:50 PDT
STR :

1) install TB - make Tb the default client
2) create an account
3) Save an email from the account
4) close TB
5) double click on saved email

Mail.app starts :(
Comment 1 Matthias Versen [:Matti] 2010-10-25 06:19:19 PDT
you mean bug 300393 ?
Comment 2 Ludovic Hirlimann [:Usul] 2010-10-25 06:24:29 PDT
*** Bug 300393 has been marked as a duplicate of this bug. ***
Comment 3 Ludovic Hirlimann [:Usul] 2010-10-25 06:24:54 PDT
(In reply to comment #1)
> you mean bug 300393 ?

Yes and I missed it when I searched.
Comment 4 Matthias Versen [:Matti] 2011-10-09 05:54:26 PDT
*** Bug 693092 has been marked as a duplicate of this bug. ***
Comment 5 Hiroyuki Ikezoe (:hiro) 2012-02-07 22:49:44 PST
Created attachment 595325 [details] [diff] [review]
Fix for Linux

This is only effective with --enable-gio option.
Comment 6 Mark Banner (:standard8) (afk until 26th July) 2012-02-08 12:46:56 PST
Comment on attachment 595325 [details] [diff] [review]
Fix for Linux

Errm, note that this bug was about mac and not linux.
Comment 7 Mike Conley (:mconley) - (Needinfo me!) 2012-02-08 13:18:16 PST
Hey Chris,

I feel like this is more your domain than mine.  How does everything look here, GIO-wise?

-Mike
Comment 8 Hiroyuki Ikezoe (:hiro) 2012-02-08 13:55:10 PST
(In reply to Mark Banner (:standard8) from comment #6)
> Comment on attachment 595325 [details] [diff] [review]
> Fix for Linux
> 
> Errm, note that this bug was about mac and not linux.

The bug for linux (and Mac), bug 300393, had been duplicated this bug..
Comment 9 Mike Conley (:mconley) - (Needinfo me!) 2012-02-13 09:37:43 PST
Comment on attachment 595325 [details] [diff] [review]
Fix for Linux

Review of attachment 595325 [details] [diff] [review]:
-----------------------------------------------------------------

Just one nit - but other than that, this looks really good to me.  Thanks Hiro.

::: mail/components/shell/nsMailGNOMEIntegration.cpp
@@ +158,5 @@
>    *aIsDefaultClient = true;
> +
> +  for (unsigned int i = 0; i < NS_ARRAY_LENGTH(sAppTypes); i++) {
> +    if (aApps & sAppTypes[i].type)
> +      *aIsDefaultClient &= checkDefault(sAppTypes[i].protocols, NS_ARRAY_LENGTH(sAppTypes[i].protocols));

I like how you've reduced the repetitive if statements we had before.  Can you break this up into two lines?
Comment 10 Hiroyuki Ikezoe (:hiro) 2012-02-13 22:30:31 PST
Created attachment 596928 [details] [diff] [review]
Revised patch

Carrying over review+.
Comment 11 Mark Banner (:standard8) (afk until 26th July) 2012-02-14 04:38:55 PST
Checked in: http://hg.mozilla.org/comm-central/rev/7150237ed78f

Branched out Mac to bug 726969 so we can track that separately.

Note You need to log in before you can comment on or make changes to this bug.