focus group name field after creating new group

VERIFIED FIXED in Firefox 7

Status

Firefox Graveyard
Panorama
P4
trivial
VERIFIED FIXED
7 years ago
a year ago

People

(Reporter: Luis Villa, Assigned: ttaubert)

Tracking

Trunk
Firefox 7
Dependency tree / graph

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
When I create a 'new folder' in finder or other file managers, the folder name field is immediately focused so that I can type the new folder's name. 

I have the same expectation when creating a new group, but instead I get search.

Current behavior:
1) click and drag to create new tab group
2) type 'foo' to name the group, hit enter
3) get told there are no search results for foo.

Expected behavior:
1) click and drag to create new tab group
2) type 'foo' to name the group, hit enter
3) the group is now named 'foo'

Would be nice for this to Just Work. :)

Comment 1

7 years ago
That certainly seems like the sort of behavior we want! Adding it to the b9 (fit n' finish beta) list so we can discuss it more when we get there.

Updated

7 years ago
Blocks: 598154

Updated

7 years ago
Priority: -- → P4

Comment 2

7 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 3

7 years ago
bugspam (removing b9)
No longer blocks: 598154

Comment 4

7 years ago
Punting
No longer blocks: 608028
Target Milestone: --- → Future
(Assignee)

Updated

6 years ago
Assignee: nobody → tim.taubert
Blocks: 660175
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Hardware: x86 → All
Target Milestone: Future → ---
(Assignee)

Comment 5

6 years ago
Created attachment 537601 [details] [diff] [review]
patch v1

@Alex: the patch focuses the title input field when using mouse drag to create a new tab group. Shall we also focus the input field when creating a group via dragging a tabItem onto an orphan tab? Without the orphan tab concept we would immediately create a new group when dragging a tab out of its group.

I don't feel like it's the right thing to focus the input field when not explicitly creating a new group but it's up to you :)
Attachment #537601 - Flags: feedback?(raymond)
Comment on attachment 537601 [details] [diff] [review]
patch v1

+  if (options.focusTitle)
+    this.focusTitle();
+

Nit: Please add a comment about options.focusTitle to the method input variable options.
Attachment #537601 - Flags: feedback?(raymond) → feedback+
(Assignee)

Comment 7

6 years ago
Comment on attachment 537601 [details] [diff] [review]
patch v1

Passed try:

http://tbpl.mozilla.org/?tree=Try&pusher=tim.taubert@gmx.de&rev=1ef959a9e308
(Assignee)

Comment 8

6 years ago
Created attachment 537755 [details] [diff] [review]
patch v2
Attachment #537601 - Attachment is obsolete: true
Attachment #537755 - Flags: review?(ehsan)
Attachment #537755 - Flags: review?(ehsan) → review+
(Assignee)

Comment 9

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/d8b5c9736831
Whiteboard: [inbound]
Backed out due to mochitest-other orange.
Whiteboard: [inbound]
(Assignee)

Comment 11

6 years ago
Created attachment 538527 [details] [diff] [review]
patch v3

Extended patch (and test) to auto-focus the title field when creating a new group by dragging a tab onto an orphan tab (as requested by Limi).
Attachment #537755 - Attachment is obsolete: true
Attachment #538527 - Flags: review?(ehsan)
Do we know what was wrong with the original patch which caused this to be backed out?
(Assignee)

Comment 13

6 years ago
(In reply to comment #12)
> Do we know what was wrong with the original patch which caused this to be
> backed out?

I relanded all other patches except bug 633190 - that was actually causing this intermittent orange. So this patch should be safe.
(Assignee)

Comment 14

6 years ago
Comment on attachment 538527 [details] [diff] [review]
patch v3

Passed try:

http://tbpl.mozilla.org/?tree=Try&pusher=tim.taubert@gmx.de&rev=3b0da64388be
Attachment #538527 - Flags: review?(ehsan) → review+
(Assignee)

Comment 15

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/d58376753a93
Whiteboard: [inbound]
(Assignee)

Comment 16

6 years ago
http://hg.mozilla.org/mozilla-central/rev/d58376753a93
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 7

Comment 17

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110615 Firefox/7.0a1

Verified issue on Ubuntu 11.04 x86, Mac OS X 10.6, Win 7 x86, WinXP using the steps from the Description.

Issue no longer present - changing status to Verified.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.