Closed Bug 607227 Opened 9 years ago Closed 9 years ago

Hide menu Bookmarks > "Bookmark all Tabs" unless the user invokes the menu using the keyboard

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 588011
Firefox 4.0b11

People

(Reporter: faaborg, Assigned: mak)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [target-betaN][fix in bug 588011][not possible on Mac])

Attachments

(1 obsolete file)

This bug is to remove the command Bookmarks > Bookmark All Tabs from the traditional menu bar.  This command is still available on the context menu of the tab strip.

The rationale is that this command had extremely low usage in our usability metrics coming from test pilot, especially relative to the surrounding very high usage menu items.  Additionally this command increases the number of commands that we have listed before the user can start viewing their actual bookmarks, which is the overall purpose of the bookmarks menu.
I think "context menu of the tab bar" is an awkward and undiscoverable location for this feature.
I can take this if the decision has been finalized to remove this.
Whiteboard: [target-betaN]
Note, for performance reasons I have a patch implementing this in Bug 588011.
The UX team is very eager to get this bug landed over the next few days in order to make Beta 11.  If anyone can get a patch for this bug posted soon, we will push hard for reviews and approval (even though this isn't blocking).

You can view all of the related bugs to clean up the traditional menu bar here: http://areweprettyyet.com/4/traditionalMenu/
taking based on comment 3
Assignee: nobody → mak77
FWIW, "Bookmark all Tabs" is a tip I published in our mainstream newsletter. It's great for when you are researching a topic.
>It's great for when you are researching a topic.

yeah, and those users are going to love tab multi-select (bug 566510) and panorama.  I'm all for people doing aggregate bookmarking, I just want it to be more direct manipulation (or at least context menu).
Bug #611568 has patch that removes "Bookmark all Tabs" from the bookmarks menu.
Disregard comment #8, I will let Marco handle this one unless he wants me to knock it out of the park real quick. =)
Uploaded this patch per limi in #developers.
Attachment #506662 - Flags: review?(dolske)
Comment on attachment 506662 [details] [diff] [review]
Removes Bookmark All Tabs from the browser menu

sorry but the string is still used in the tabs context menu, as well as the command, plus this is not the way we intend to remove this menuitem (as others items we are removing it should still appear for keyboard access, like the ones in Bug 626825)
Attachment #506662 - Flags: review?(dolske) → review-
fixed in bug 588011
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 588011
Resolution: --- → FIXED
Whiteboard: [target-betaN] → [target-betaN][fix in bug 588011]
Target Milestone: --- → Firefox 4.0b11
Attachment #506662 - Attachment is obsolete: true
Flags: in-litmus?
To clarify the behavior, mouse interactions won't see the entry in the menu, while keyboard interactions will see it (to expose the keyboard shortcut).

The removal is based on the functionality implemented in bug 607224.
Depends on: 607224
This bug has been marked for all platforms. But with todays nighlty build on OS X the menu entry is still visible.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 4.0b11 → ---
Asking for blocking now that it hasn't been fixed by bug 588011.
blocking2.0: --- → ?
(In reply to comment #14)
> This bug has been marked for all platforms. But with todays nighlty build on OS
> X the menu entry is still visible.

that's the wanted behavior, bug 607224 doesn't work on Mac.
Status: REOPENED → RESOLVED
blocking2.0: ? → ---
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Whiteboard: [target-betaN][fix in bug 588011] → [target-betaN][fix in bug 588011][not possible on Mac]
Thanks for the clarification Marco. Marking as verified fixed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre

Litmus test has been updated:
https://litmus.mozilla.org/show_test.cgi?id=10033
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
Target Milestone: --- → Firefox 4.0b11
Version: unspecified → Trunk
Adjusting summary to the fix (to correct awpy), and duping to bug 588011 where it happened.
Status: VERIFIED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: FIXED → DUPLICATE
Summary: Remove "Bookmark all Tabs" from the bookmarks menu → Hide menu Bookmarks > "Bookmark all Tabs" unless the user invokes the menu using the keyboard
Duplicate of bug: 588011
You need to log in before you can comment on or make changes to this bug.