Closing tabs from browser window causes tab group layouts to be borked

VERIFIED FIXED in Firefox 4.0b10

Status

defect
P2
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: mozbugz, Assigned: ttaubert)

Tracking

Trunk
Firefox 4.0b10
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker])

Attachments

(2 attachments)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101025 Firefox/4.0b8pre
Build Identifier: 

Open lots of tabs, go to Tab Candy and make sure they are in a group.  Then go back to the browser view and close several tabs.  Go back to Tab groups and notice larger thumbnails and layout off the tab group.  Which you have to manually fix.

Reproducible: Sometimes
Reporter

Updated

9 years ago
Version: unspecified → Trunk
Reporter

Updated

9 years ago
blocking2.0: --- → ?

Updated

9 years ago
Blocks: 598154
OS: Windows 7 → Windows XP
Priority: -- → P2
Blocking+, that screenshot tells the story.
blocking2.0: ? → final+
I couldn't replicate this.  Is there a reliable way to reproduce this?
OS: Windows XP → All
I can't reproduce this either. 

reporter, please provide more information about your setup (other extensions etc) and more accurate details as to how many tabs.
Reporter

Comment 5

9 years ago
I think its kind of hard to reproduce but I've seen it happen more than once in the past few months.  It might require a few groups be created and tabs to be restored, then removed and then going into tabcandy.  

Though, now I'm thinking maybe this bug might be possibly improved or fixed by bug 602777, which has mention of arranging and grouping changes, only time will tell if A) clear STR exist B) its only reproduce able before that bug landed.
I've seen something like this: http://grab.by/7t9N I'm hoping it's due to bug 607016 though.

I've yet to see this actually happen in a single session only across sessions, so perhaps it's not the same thing.

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dennis, can you see if this works tomorrow? The next nightly should have my fix for bug 607016 in it and I'd like to know if it's still an issue.
Reporter

Comment 8

9 years ago
This I think is similar.  I found this after I actually restarted the browser several times since I used tabs in other group several times.  There appears to be a problem with sizing the thumbnails, maybe its not checking or updated the dimensions in each group when you enter Panorama.

This is using the most recently nightly.

Comment 9

9 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 10

9 years ago
bugspam (removing b9)
No longer blocks: 598154
Whiteboard: [softblocker]
Looking at the screenshot I am pretty sure this is fixed when the patch for bug 624953 lands.
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
Depends on: 624953
softblocker = critical
Severity: normal → critical
Severity: critical → normal
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
verified with minefield build of 20110217
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.