Received date isn't set correctly for IMAP messages

RESOLVED DUPLICATE of bug 402594

Status

RESOLVED DUPLICATE of bug 402594
8 years ago
8 years ago

People

(Reporter: pjemen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11 ( .NET CLR 3.5.30729; .NET4.0E) XPCOMViewer/0.9.2
Build Identifier: 

I have noticed that Received date isn't set correctly on IMAP account (tested on Ms Exchange and Davecot). It seems that received date that is shown in nsMsgDBView in column received is set here
http://mxr.mozilla.org/comm-1.9.2/source/mailnews/local/src/nsParseMailbox.cpp#1597

In case of IMAP message there isn't fetched field Received because url processed in IMAP thread look like this 
13 UID fetch 246 (UID RFC822.SIZE FLAGS BODY.PEEK[HEADER.FIELDS (From To Cc Bcc Subject Date Message-ID Priority X-Priority References Newsgroups In-Reply-To Content-Type)])

In this case it is used field Date to set as received date.


Reproducible: Always

Steps to Reproduce:
Send this message to a IMAP account and take a look at column Received and Date:

Subject: Test spam mail (GTUBE)
Message-ID: <GTUBE1.1010101@example.net>
Date: Wed, 23 Jul 2003 23:30:00 +0200
From: Sender <sender@example.net>
To: Recipient <recipient@example.net>
Precedence: junk
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

This is the GTUBE, the
	Generic
	Test for
	Unsolicited
	Bulk
	Email

If your spam filter supports it, the GTUBE provides a test by which you
can verify that the filter is installed correctly and is detecting incoming
spam. You can send yourself a test mail containing the following string of
characters (in upper case and with no white spaces and line breaks):

XJS*C4JDBQADN1.NSBN3*2IDNEN*GTUBE-STANDARD-ANTI-UBE-TEST-EMAIL*C.34X

You should send this test mail from an account outside of your network.

Actual Results:  
Received and Date are set to 23 Jul 2003 23:30:00 +0200

Expected Results:  
Date should be 23 Jul 2003 23:30:00 +0200
Received should be taken from last Received field of message header.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
Prolem is already reported as bug 402594.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402594
You need to log in before you can comment on or make changes to this bug.