text inside deeply nested font tags isn't displayed

VERIFIED DUPLICATE of bug 58917

Status

()

Core
HTML: Parser
P3
major
VERIFIED DUPLICATE of bug 58917
17 years ago
10 years ago

People

(Reporter: simo.sorce, Assigned: harishd)

Tracking

Trunk
mozilla1.0.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Tested on Mozilla 20001113 for Linux and Netscape 6 for Linux and Windows.

The page is rendered only partially (first 20 rows on any system)

Comment 1

17 years ago
Also seeing this on build 20001119 on Win2k.
Renders ok in Netscape 4.76
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: show stopper → page is rendered only partially

Comment 2

17 years ago
This bug really about the number of open tags (in this page <font> tags) that
Mozilla has handle.
Check out the attached testcase.

Comment 3

17 years ago
Created attachment 19502 [details]
Testcase with many open font tags. Check the source code, since deleting one line revealse more text...

Comment 4

17 years ago
Is this the mostfreq penguin from bug 18480 ?

Comment 5

17 years ago
But bug 18480 is marked fix. That was a crasher...

Updated

17 years ago
Component: Browser-General → Parser

Comment 6

17 years ago
this version of the same ascii-art, loads OK.
http://www.autsch.de/bitsteller/linux_penguin.html
(It used to load extremely slow if at all)

Comment 7

17 years ago
reassinging for real, but perhaps layout?
Assignee: asa → harishd
QA Contact: doronr → janc
(Assignee)

Comment 8

17 years ago
Due to stack over flow problems in layout, the parser has put an upper limit ( I
think it's about 100 ) to the tag nesting level.

Comment 9

17 years ago
That's an ugly limitation of the parser. Is this a permenently hack or fix?
(Assignee)

Comment 10

17 years ago
It's certainly a hack. We are working on a complete solution for this problem.

Updated

17 years ago
Summary: page is rendered only partially → text inside deeply nested font tags isn't displayed
(Assignee)

Comment 11

17 years ago
Giving bug to rickg since he worked on this problem.
Assignee: harishd → rickg
nominating for m0.9/nsbeta1
Keywords: mozilla0.9, nsbeta1
*** Bug 68968 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
updated qa contact.
QA Contact: janc → bsharma

Comment 15

17 years ago
*** Bug 82260 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Rick left, giving back to Harish.  :)
Assignee: rickg → harishd
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.3
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla1.0.1
This is the same as bug 58917.  Marking DUPLICATE.  See also recent discussion 
in n.p.m.general and bug 49678.

*** This bug has been marked as a duplicate of 58917 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: bsharma → moied

Comment 18

16 years ago
Marking verified duplicate of 58917
Status: RESOLVED → VERIFIED
*** Bug 154750 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.