Test for bug 595930 takes too long to run

RESOLVED FIXED in Firefox 4.0b8

Status

defect
P2
normal
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: raymondlee, Assigned: raymondlee)

Tracking

Trunk
Firefox 4.0b8
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment, 4 obsolete attachments)

The browser_tabview_bug595930 takes too long to run because it waits until the group item is closed (including 15seconds for the undo group button to dismiss).  We should speed it up by setting groupItem.fadeAwayUndoButtonDelay and  groupItem.fadeAwayUndoButtonDuration but we need to wait until patch for bug 595521 to land first.
Assignee: nobody → raymond
Blocks: 597043
Depends on: 595521
Priority: -- → P2
(In reply to comment #0)
> The browser_tabview_bug595930 takes too long to run because it waits until the
> group item is closed (including 15seconds for the undo group button to
> dismiss).  We should speed it up by setting groupItem.fadeAwayUndoButtonDelay
> and  groupItem.fadeAwayUndoButtonDuration but we need to wait until patch for
> bug 595521 to land first.

Ignore the above please.  The problem is that the ctrl+e is used before the group is ready.  The patch fixes the problem.  Sent it to try.
Posted patch v1 (obsolete) — Splinter Review
Attachment #486326 - Flags: feedback?(ian)
Attachment #486326 - Attachment is patch: true
Attachment #486326 - Attachment mime type: application/octet-stream → text/plain
s/appriopate/appropriate/
Posted patch v1 (obsolete) — Splinter Review
Fixed a typo
Attachment #486326 - Attachment is obsolete: true
Attachment #486329 - Flags: feedback?(ian)
Attachment #486326 - Flags: feedback?(ian)
Status: NEW → ASSIGNED
Comment on attachment 486329 [details] [diff] [review]
v1

Perhaps you could put a little more detail in the comments in the code about why you need the delay? Otherwise looks good.
Attachment #486329 - Flags: feedback?(ian) → feedback+
Posted patch v1 (obsolete) — Splinter Review
f=ian.  Updated the comment.
Attachment #486329 - Attachment is obsolete: true
Attachment #486558 - Flags: review?(dolske)
Attachment #486558 - Flags: review?(dolske)
Attachment #486558 - Flags: review+
Attachment #486558 - Flags: approval2.0?
Posted patch v1 (obsolete) — Splinter Review
Sent it to try 301a9cc7f739, waiting for the result

r=ian
Attachment #486558 - Attachment is obsolete: true
Attachment #490774 - Flags: approval2.0?
Attachment #486558 - Flags: approval2.0?
(In reply to comment #7)
> Created attachment 490774 [details] [diff] [review]
> v1
> 
> Sent it to try 301a9cc7f739, waiting for the result
> 
> r=ian

Passed try
Comment on attachment 490774 [details] [diff] [review]
v1

a=beltzner, good test-driven bug!
Attachment #490774 - Flags: approval2.0? → approval2.0+
Attachment #490774 - Attachment is obsolete: true
Keywords: checkin-needed
Attachment #492710 - Attachment is patch: true
Attachment #492710 - Attachment mime type: application/octet-stream → text/plain
Keywords: checkin-needed
Passed try
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/dcc94ba87c5c
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
Whiteboard: [qa-]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.