Closed Bug 607908 Opened 12 years ago Closed 1 year ago

"Clear recent history" does not clear persistent state kept by plugins

Categories

(Core Graveyard :: Plug-ins, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: usenet, Unassigned)

References

(Blocks 1 open bug)

Details

"Clear recent history" should clear _all_ recent history. It currently does not clear persistent data saved by plugins such as Flash, commonly known as "flash cookies"

Since users may be under the impression that clearing their history in Firefox will clear all persistent browser state, and mistakenly rely on this to protect their privacy, this presents a mechanism for unsuspecting users to leak private information. 

Probably the best way to resolve this is for there to be an API for plugins to be informed that they need to clear their saved states, and plugins should honour those requests.

As an alternative, if plugins cannot or will not support this, Firefox could be provided with a list of files and directories that should be deleted in order to clear the persistent state of common plugins.

Note that this is a distinct issue from private browsing mode: clearing history should be able to clear all browser and plugin state, even after non-private browsing.
I don't see a bug for it (so maybe this becomes that bug), but this feature has been proposed: https://wiki.mozilla.org/NPAPI:ClearPrivacyData

Firefox clearing the files on its own isn't very practical except maybe in the special case of Flash, and the Flash team is the one most interested in implementing this API.
Component: Security → Plug-ins
Product: Firefox → Core
QA Contact: firefox → plugins
Version: unspecified → Trunk
Duplicate of this bug: 685136
From bug 685136 comment 6:
> My bad - works for me now. Firefox did not delete Flash cookies (and regular
> cookies) for a few restart cycles (maybe the FF instance did not shut down
> properly, never checked), but now it does.

Can anyone confirm this?
Blocks: 1102808
Priority: -- → P3
Resolving as wont fix, plugin support deprecated in Firefox 85.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.