Closed Bug 608009 Opened 9 years ago Closed 9 years ago

update verify scripts should support some sort of chunking

Categories

(Release Engineering :: General, defect, P4)

All
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 589251

People

(Reporter: bhearsum, Assigned: bhearsum)

References

Details

We added "chunking" support to mochitests awhile ago in order to parallelize it. The update verify scripts should support a similar mechanism both in the "do the MARs apply and match the installer" tests and the "check previous snippets" test.

The implementation doesn't have to look like mochitest chunking at all, but it may fit well here.

Doing this would let us speed up end 2 end time on releases, and make bug 408453 something we could do in a reasonable amount of time.
Priority: -- → P4
Depends on: 608011
Blocks: 608011
No longer depends on: 608011
Assignee: nobody → bhearsum
Duping to more general bug
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589251
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.