Message Display panel clipped on Windows 7

RESOLVED FIXED in seamonkey2.8

Status

RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: InvisibleSmiley, Assigned: ewong)

Tracking

Trunk
seamonkey2.8
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

8 years ago
Created attachment 486743 [details]
Message Display cropped

The Message Display and Keyboard Navigation pref panels are clipped on Windows 7 (default system DPI and font settings). See attached images.
(Reporter)

Comment 1

8 years ago
Created attachment 486744 [details]
Keyboard Navigation cropped
(Reporter)

Comment 2

8 years ago
I already checked on Linux and Windows XP, no problem there. This is Win7-only.
(Reporter)

Updated

8 years ago
Attachment #486744 - Attachment description: Keybaord Navigation cropped → Keyboard Navigation cropped

Comment 3

8 years ago
I played around with some user styles in Stylish and came up with this:

@-moz-document url(chrome://communicator/content/pref/preferences.xul) {
  radio,
  checkbox {
    margin-top: 0.5px !important;
    margin-bottom: 0.5px !important;
  }
}

0px works better but looks a bit cramped.

Comment 4

8 years ago
You may want to use the |:-moz-system-metric(windows-default-theme)| pseudo selector to limit the effects to Windows.
(Reporter)

Comment 5

8 years ago
(In reply to comment #3)
> I played around with some user styles in Stylish and came up with this:

Yes, that does the trick. I can f+ a patch if you come up with one. ;-)

Comment 6

8 years ago
You need to check the appearance in all the other panels. And also on Modern/Win7

Comment 7

8 years ago
OK not Modern since these styles will go into the classic theme.
(Reporter)

Comment 8

8 years ago
(In reply to comment #6)
> You need to check the appearance in all the other panels.

O'Really? I did. Anyway, we need a patch. Will try to come up with something later today, unless the bug has been assigned until then.
(Assignee)

Comment 9

8 years ago
Is this bug still valid?   Keyboard Navigation has changed such that 
find as you type section has moved to its own preference category and
on my current build:

Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110424 Firefox/4.2a1pre SeaMonkey/2.2a1pre

The Message Display displays ok.
(Reporter)

Comment 10

8 years ago
Keyboard Navigation is OK now, adjusting summary.

Message Display is still affected; I still see attachment 486743 [details].
Summary: Message Display and Keyboard Navigation panels clipped on Windows 7 → Message Display panel clipped on Windows 7
(Reporter)

Updated

8 years ago
Attachment #486744 - Attachment is obsolete: true
(Reporter)

Updated

8 years ago
Duplicate of this bug: 676337
(Assignee)

Updated

7 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
(Assignee)

Comment 12

7 years ago
Created attachment 557485 [details] [diff] [review]
Message Display panel clipped on Windows 7
Attachment #557485 - Flags: review?(iann_bugzilla)

Comment 13

7 years ago
Comment on attachment 557485 [details] [diff] [review]
Message Display panel clipped on Windows 7

I think this needs feedback from some non-English locales as it might not look very good when you have longer labels. Perhaps Mnyromyr?

Comment 14

7 years ago
Comment on attachment 557485 [details] [diff] [review]
Message Display panel clipped on Windows 7

Re-request review once you have had some f+
Attachment #557485 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

7 years ago
Attachment #557485 - Flags: feedback?(jh)
I've tried a Russian language and it seems o.k. but the labels there are wrapped on two lines with or without the patch, if that's important.
Created attachment 558551 [details]
Russian locale - w/o patch
Created attachment 558552 [details]
Russian locale - with patch
(Reporter)

Updated

7 years ago
Attachment #557485 - Flags: feedback?(jh) → feedback?(stanio)

Updated

7 years ago
Attachment #557485 - Flags: feedback?(stanio) → feedback+
(Reporter)

Comment 18

7 years ago
FTR: Generally it's bad to align checkboxes horizontally (because it makes it hard to tell the checkbox-label relationship) but in this case there's enough space in between.

Comment 19

7 years ago
> -      <vbox align="start">
> +      <hbox align="start">
Shouldn't this be <hbox pack="start"> ? changing the orientation of the box changes the direction of align and pack.

https://developer.mozilla.org/en/XUL_Tutorial/Element_Positioning#Box_Alignment
https://developer.mozilla.org/en/XUL/align
https://developer.mozilla.org/en/CSS/box-pack
(Assignee)

Comment 20

7 years ago
Created attachment 572266 [details] [diff] [review]
Message Display panel clipped on Windows 7 (v2) [Checkin: comment 21]
Attachment #557485 - Attachment is obsolete: true
Attachment #572266 - Flags: review?(iann_bugzilla)
Attachment #572266 - Flags: feedback+

Updated

7 years ago
Attachment #572266 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
(Reporter)

Comment 21

7 years ago
Comment on attachment 572266 [details] [diff] [review]
Message Display panel clipped on Windows 7 (v2) [Checkin: comment 21]

http://hg.mozilla.org/comm-central/rev/18d9e519334f
Attachment #572266 - Attachment description: Message Display panel clipped on Windows 7 (v2) → Message Display panel clipped on Windows 7 (v2) [Checkin: comment 21]
(Reporter)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.8

Updated

6 years ago
Depends on: 867210
You need to log in before you can comment on or make changes to this bug.