Segmentation Fault When Setting cookie via http from 127.0.0.1

RESOLVED FIXED

Status

()

P3
minor
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: dustacio, Assigned: morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Whenever a cookie is set from the local httpd daemon usign the url
http://127.0.0.1 the browser will crash with
./run-mozilla.sh: line 72: 7485 Segmentation fault  $prog ${1+"$@"}
However, replace 127.0.0.1 with the hostname and everything works flawlessly.
This might be related to #19427, Results with nightly build 20-Nov-2000 and
build from 18-Nov-2000
(Assignee)

Comment 1

18 years ago
I doubt that this has anything to do with bug 19427.  But I suspect this is 
strongly related to bug 55878.  Although the symptoms are slightly different, 
both are involved with crashes when visiting 127.0.0.1.
(Assignee)

Comment 2

18 years ago
Fix for bug 56644 has been checked in.  That patch also contained a fix for bug 
55878 which, as I mentioned above, I suspect is the cause of the crash reported 
here.

Therefore closing this out as fixed.  If the problem is still occuring, then 
please reopen this report and give a detailed set of steps for reproducing this 
crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.