Closed Bug 608268 Opened 9 years ago Closed 9 years ago

URL bar horizontal scrolling is broken after sharing a page through twitter

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec-)

VERIFIED FIXED
Tracking Status
fennec - ---

People

(Reporter: ioana.chiorean, Assigned: vingtetun)

Details

(Keywords: polish)

Attachments

(3 files)

Attached image left panel
Build Identifier: Mozilla/5.0 (Maemo; Linux armv7l; en-US; rv:2.0b8pre)
Gecko/20101029 Firefox/4.0b8pre Fennec/4.0b2pre 

Device: Nokia N900

Steps to Reproduce:
1. Open an internet page
2. Tap the favicon-> choose share page
3. From the prompted options choose Twitter

Actual Results:  
- the twitter page should cause problems to the URL bar

Expected Results:  
- the URL bar doesn't remain fix when panning in left or right pages-  see attached photos
Attached image right
This only seems to happen when opening twitter via a "share page", not navigating directly to twitter. Refreshing the page seems to fix the problem too.

I am not to worried about the actual use case here. Sharing via the twitter link is only active for the N900. I am worried about why it's happening.
Assignee: nobody → 21
tracking-fennec: --- → 2.0b3+
I can reproduce this on deskop too, not sure what's happening too. I will look at it tomorrow
Build Identifier: Mozilla/5.0 (Android; Linux armv7l; en-US; rv:2.0b7pre)
Gecko/20101101 Firefox/4.0b8pre Fennec/4.0b2pre 

Device: HTC Desire 

Steps to Reproduce:
1. Go to Addons Manager -> instal the recommended add-on readability
2. Open an internet page
3. Tap the favicon-> choose Make Readable

Note:
please see : 
- http://www.facebook.com/photo.php?pid=31901&l=a0c236d411&id=100001755601293
- http://www.facebook.com/photo.php?pid=31900&l=3f7efdb1f2&id=100001755601293
tracking-fennec: 2.0b3+ → 2.0-
Keywords: polish
Summary: URL bar larger than usual at sharing a page through twitter → URL bar horizontal scrolling is broken after sharing a page through twitter
Attached patch PatchSplinter Review
The patch add a tryFloatToolbar call to hideSidebars, I'm not sure why there isn't such a call already here?
Attachment #493964 - Flags: review?(mark.finkle) → review+
Whiteboard: [fennec-checkin-postb3]
pushed:
http://hg.mozilla.org/mobile-browser/rev/df1cc5afcff9
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fennec-checkin-postb3]
This caused a regression on Android:  When you press the "new tab" button in portrait mode, the soft keyboard appears and then immediately disappears.

I think maybe unfloating the toolbar while it is focused is resetting the IME state or recreating the frame or something.

Backed out for now: http://hg.mozilla.org/mobile-browser/rev/9cfb88750198
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #8)
> This caused a regression on Android:  When you press the "new tab" button in
> portrait mode, the soft keyboard appears and then immediately disappears.

I just saw this in today's nightly build (with the backout), so maybe it was actually unrelated.  It seems to be intermittent; I can't reproduce it reliably.
I filed bug 618317 for the regression.  It looks like it wasn't actually fixed by the backout, so this patch should be safe to re-land.
re-pushed: 
http://hg.mozilla.org/mobile-browser/rev/66b5adac5e2a
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101213 Namoroka/4.0b8pre Fennec/4.0b3pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101213 Namoroka/4.0b8pre Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
OS: Android → All
Hardware: ARM → All
You need to log in before you can comment on or make changes to this bug.