mozilla slows to a crawl on this site

RESOLVED DUPLICATE of bug 52798

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 52798
17 years ago
17 years ago

People

(Reporter: Mike Palczewski, Assigned: clayton)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I'm using a nov16 nightly of mozilla. Mozilla slows to a crawl on this site.
Even after it is loaded. This is under linuxppc, I belive this has happened on
an x86 M18 also.

Comment 1

17 years ago
I'm seeing this as well on a 2000-11-18-20 build on NT4. Mozilla is taking all
CPU cycles it can get.

Comment 2

17 years ago
someone want to testcase this one. Over to Layout.
Assignee: asa → clayton
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 3

17 years ago
I've narrowed down the HTML to a single table plus the images, and put it on a
page at http://cheeze.org/test/ -- please take a look. CPU is definitely spiked.
Seems to be related to loading the small GIF images; if I comment out half of
the images, the CPU spike is cut in half.

Comment 4

17 years ago
These images are animated GIFs, each animation frame being exactly the same.
(Don't know why anyone would do this ...)

So pressing stop reduces the CPU load to nearly zero.

Comment 5

17 years ago
Before I pressed STOP, Mozilla kept repeating the GET requests for the images
over and over. That shouldn't happen.

Comment 6

17 years ago
Is there a Linux for Macintosh? ;)

I also see this on w2k.
OS: Linux → All
Hardware: Macintosh → All
(Reporter)

Comment 7

17 years ago
"Is there a Linux for Macintosh?"

Yes there is. I'm writing this using mozilla running on linux running on an ibook.

Comment 8

17 years ago
Using the specfied URL, I can't reproduce the problem in the 12/12 branch build.
Checked under Mac OS 9 and Linux Redhat 6.0.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 9

17 years ago
Marking verified worksforme.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

17 years ago
I think this bug needs to be reopened. I'm not sure how you failed to see this.
I go to this page and mozilla slows down, this is on a Dec 15th build on redhat
linux 7.0. This also happens on a December 12th build on LinuxPPC. Other people
have verified that this happens on windows2000. Mozilla slows almost to an
unusable state and under linux the mouse cursor blinks all the time. If I open
top I see mozilla using 100% of the cputime. I can't believe you would just
ignore this serious bug.

Comment 11

17 years ago
*** Bug 67316 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
This doesn't work at all - takes all CPU it can get. Reopening.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 13

17 years ago
Confirmed problem still exists with linux build 2001020108 for the given URL.
(Reporter)

Comment 14

17 years ago
This seams very similar to bug 52798. 

*** This bug has been marked as a duplicate of 52798 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
What does this bug have to do with flashing/reloading graphics? I fail to see
the connection.
(Reporter)

Comment 16

17 years ago
In response to the previous question this has to do with the fact that both
these bugs were caused by too many reflows. 
Mozilla kept on rerendering the page. This has since been fixed. If you go to
the site with a recent build you will notice that mozilla remains reponsive and
consumes about as much cpu time as it would on any other page. Hope that made sense.
You need to log in before you can comment on or make changes to this bug.