Closed Bug 608810 Opened 12 years ago Closed 12 years ago

Yahoo Mail error when opening an email

Categories

(Core :: XPConnect, defect)

x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla2.0

People

(Reporter: jcspence74, Assigned: dvander)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b8pre) Gecko/20101101 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b8pre) Gecko/20101101 Firefox/4.0b8pre

Yahoo Mail crashes when opening an email today's buid (Gecko/20101101 Firefox/4.0b8pre).  I believe this is a JavaScript bug.  Yesterdays build (Gecko/20101031 Firefox/4.0b8pre) worked fine with Yahoo Mail.

Reproducible: Always

Steps to Reproduce:
1. Go to mail.yahoo.com
2. I Went to Spam Folder, but Inbox broken also
3. Open email
4. I got the popup message "toMessage"
5. Clicked OK and redirected to blank white page.
6. Afterwards sometimes clicking on an email, I get no popup.. just blank white page.
Actual Results:  
I get a blank whit page.

Expected Results:  
I should be reading the email message
blocking2.0: --- → ?
Version: unspecified → Trunk
Attached image Screenshot
Attachment #487407 - Attachment description: Screenshoot → Screenshot
Yahoo! Mail turns into a blank tab after I click any folder or message on Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101101 Firefox-4.0/4.0b8pre
I'm on Windows 7 and while crash it totally and utterly the wrong word. There is a critical problem with the worlds number one webmail provider on Minefield.
It happens on "new Yahoo! Mail". not happens on "Mail classic".

Regression Window TM build:
Works:
http://hg.mozilla.org/tracemonkey/rev/66f4a212edeb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101029 Firefox/4.0b8pre ID:20101029043450
Fails;
http://hg.mozilla.org/tracemonkey/rev/4a6259d13882
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101029 Firefox/4.0b8pre ID:20101029111029
Pushlog:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=66f4a212edeb&tochange=4a6259d13882
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Target Milestone: --- → mozilla2.0
Can you go to about:crashes and link a crash id?
Crashes : bp-433a0c11-089d-4a1b-99d9-4a7562101101
In my case, It is rare to crash.
Most problems are to become blank tab.
(In reply to comment #5)
> Can you go to about:crashes and link a crash id?

It doesn't crash the browser.. just the website, Yahoo Mail (not classic).
The stack in #6 looks pretty interesting. Blake, take a look.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: general → nobody
Component: JavaScript Engine → XPConnect
QA Contact: general → xpconnect
Alice, are you sure the patch you identified in #4 is the regressor?
(In reply to comment #9)
> Alice, are you sure the patch you identified in #4 is the regressor?

I get the same regression range on Linux.

Works:
http://hg.mozilla.org/tracemonkey/rev/66f4a212edeb
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13pre) Gecko/20101101 Firefox/4.0b8pre ID:20101029040910
Fails(become blank):
http://hg.mozilla.org/tracemonkey/rev/4a6259d13882
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13pre) Gecko/20101101 Firefox/4.0b8pre ID:20101029103532
Blocks: 604031
Summary: Yahoo Mail crashes when opening an email → Yahoo Mail error when opening an email
I can get access to Yahoo Mail but when I try to load it, I get a blank screen. This is on Win 7 64Bit
Blocking beta7 until we get some sort of resolution on this.

QA, can you please try to repro?
blocking2.0: ? → beta7+
When was m-c last merged to b7? If the regression range is real, the regressing patch is only 2-3 days old.
b7 == mozilla-central, we've abandoned the beta7 rel branch and we're releasing beta7 straight off of mozilla-central.
(In reply to comment #10)
> Works:
> http://hg.mozilla.org/tracemonkey/rev/66f4a212edeb
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13pre) Gecko/20101101
> Firefox/4.0b8pre ID:20101029040910

I don't understand this UA -- the rv: doesn't match the Firefox version.  If the UA is right then it's not just 64-bit (i686 here), so it would be good to get confirmation.

> Fails(become blank):
> http://hg.mozilla.org/tracemonkey/rev/4a6259d13882
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13pre) Gecko/20101101
> Firefox/4.0b8pre ID:20101029103532

Similarly.
Okay, I got confused by "GECKO20b7pre_20101029_RELBRANCH". I'll try to repro shortly and backout bug 604031 if it's the cause.
Marcia is also trying to repro.
(In reply to comment #17)
> Marcia is also trying to repro.

already done, see email :)

I was able to reproduce the blank page on:

Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101102 Firefox/4.0b8pre

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101102 Firefox/4.0b8pre

and Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101102 Firefox/4.0b8pre

but not the crash.

Webconsole showed a error shortly the yahoo mail page turned blank:

10:17:53.612: Exception: uncaught exception: [Exception... "Could not convert JavaScript argument"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: http://mail.yimg.com/d/combo?/gx/t11a/js/yui_loader/ba87c64b1f20e3e7898b0dc28b2173a6_1.js&/gx/t11a/js/combo/init/de/aa800e29e7dc72327f307730356a731f_1.js&/pim/r/dclient/cg504_5/js/de/strings.js&/pim/r/dclient/cg504_5/js/main/main.js&/pim/r/dclient/cg504_5/js/themes/0215016d03d3c329e4f39cf2fac65dbc_1.js&/bc/bc_2.0.4.js&/pim/r/dclient/cg504_5/js/openmail_init/openmail_init.js :: anonymous :: line 23"  data: no] Source File:  Line: 0, Column: 0 Category: content javascript

10:17:53.754: Exception: uncaught exception: [Exception... "Could not convert JavaScript argument"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: http://mail.yimg.com/d/combo?/gx/t11a/js/yui_loader/ba87c64b1f20e3e7898b0dc28b2173a6_1.js&/gx/t11a/js/combo/init/de/aa800e29e7dc72327f307730356a731f_1.js&/pim/r/dclient/cg504_5/js/de/strings.js&/pim/r/dclient/cg504_5/js/main/main.js&/pim/r/dclient/cg504_5/js/themes/0215016d03d3c329e4f39cf2fac65dbc_1.js&/bc/bc_2.0.4.js&/pim/r/dclient/cg504_5/js/openmail_init/openmail_init.js :: anonymous :: line 23"  data: no] Source File:  Line: 0, Column: 0 Category: content javascript
(In reply to comment #15)
> (In reply to comment #10)
> > Works:
> > http://hg.mozilla.org/tracemonkey/rev/66f4a212edeb
> > Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13pre) Gecko/20101101
> > Firefox/4.0b8pre ID:20101029040910
> 
> I don't understand this UA -- the rv: doesn't match the Firefox version.  If
> the UA is right then it's not just 64-bit (i686 here), so it would be good to
> get confirmation.
> 
> > Fails(become blank):
> > http://hg.mozilla.org/tracemonkey/rev/4a6259d13882
> > Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13pre) Gecko/20101101
> > Firefox/4.0b8pre ID:20101029103532
> 
> Similarly.

I set general.useragent.override to UA spoofing, because yahoo! say "Hmm...your browser is not officially supported."
Assigning to dvander.  Thanks, David!
Assignee: nobody → dvander
Yes, please back out bug 604031
I have backed out bug 604031 on m-c after confirming that it fixes the issue.
Alice, can you verify?
It works good for me with lastest hourly (mozilla-central-win32/1288726053)
Works for me on Windows and Linux recent hourly build.
http://hg.mozilla.org/mozilla-central/rev/b192fa5cfffc

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101101 Firefox/4.0b8pre ID:20101102122733
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101102 Firefox/4.0b8pre ID:20101102110409
Duplicate of this bug: 609000
Duplicate of this bug: 609082
I'm going to remove the blocking flag as this has now been backed out of m-c.
blocking2.0: beta7+ → ---
Blocks: 609200
The New Yahoo Mail Beta works. Try This http://features.mail.yahoo.com/
To expand on comment 28....

This bug was a regression from bug 604031. We backed bug 604031 out of mozilla-central (before beta 7), which caused this regression to go away. It is unclear if an updated bug 604031 is going to land on m-c again as it isn't currently marked as a blocker. If so, we'll want to make sure this bug doesn't manifest again after landing. If not, this bug is invalid and can go away.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.