External links from within app tabs should always open in new tabs [Port Firefox Bug 575561]

RESOLVED DUPLICATE of bug 610736

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 610736
8 years ago
5 years ago

People

(Reporter: Philip Chee, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
While testing one of my tabbrowser patches on trunk I keep getting:

Error: 'JavaScript component does not have a method named: "onBeforeLinkTraversal"' when calling method: [nsIXULBrowserWindow::onBeforeLinkTraversal] = NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED

I guess we need to implement the onBeforeLinkTraversal method in the front end since the backend expects it.

Firefox: Bug 575561 - External links from within app tabs should always open in new tabs instead of replacing the app tab's page
Changeset: http://hg.mozilla.org/mozilla-central/rev/b642534688f8

Should be just a SMOP.
(Reporter)

Updated

8 years ago
Depends on: 610736
Summary: Implement |onBeforeLinkTraversal| from Firefox Bug 575561 → External links from within app tabs should always open in new tabs [Port Firefox Bug 575561]
(Reporter)

Comment 1

8 years ago
Fixed in Bug 610736 Port a number of recent places changes
http://hg.mozilla.org/comm-central/rev/65159580f815
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610736
See Also: → bug 954030
You need to log in before you can comment on or make changes to this bug.