Last Comment Bug 610736 - Port a number of recent places changes
: Port a number of recent places changes
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: All All
: -- normal (vote)
: seamonkey2.1b2
Assigned To: Robert Kaiser
:
:
Mentors:
: 609034 (view as bug list)
Depends on: 424542 458026 477882 574688
Blocks: 609034 631770
  Show dependency treegraph
 
Reported: 2010-11-09 11:52 PST by Robert Kaiser
Modified: 2011-02-05 02:43 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
port those bugs (25.33 KB, patch)
2010-11-10 11:20 PST, Robert Kaiser
neil: review+
Details | Diff | Splinter Review

Description Robert Kaiser 2010-11-09 11:52:29 PST
I have a list of recent places changes in Firefox I need to go through and see to port them to SeaMonkey.
Comment 1 Robert Kaiser 2010-11-09 12:31:29 PST
Note that bug 574688 is only on the list for the sidebar changes, which are independent of the actual statusbar-realted changes.
Comment 2 Robert Kaiser 2010-11-10 11:20:32 PST
Created attachment 489558 [details] [diff] [review]
port those bugs

Due to bug 611001 not having been done, I needed to add the .markPageAsFollowedLink() somewhere else but I seem to have found the right spot, so that the test succeeds. I hope the other changes are easy to verify and not too controversial...
Comment 3 Robert Kaiser 2010-11-10 11:25:12 PST
Oh, I forgot to mention that I took the chance to take care of the merging of the sidebarUtils as they have been practically identical for bookmarks and history anyhow.

As a side note, onBeforeLinkTraversal has been introduced for bug 575561, which is an app tab matter, but I saw errors in the console due to this method missing (when executing the markPageAsFollowedLink test), so I implemented it in a dummy version.
Comment 4 neil@parkwaycc.co.uk 2010-11-14 09:29:04 PST
Comment on attachment 489558 [details] [diff] [review]
port those bugs

>+  // Called before links are navigated to to allow us to retarget them if needed.
>+  onBeforeLinkTraversal: function(originalTarget, linkURI, linkNode, isAppTab) {
>+    // We doesn't support app tabs yet but are seeing failures without this.
The method was added to nsIXULBrowserWindow.idl so a) the implementation belongs after setOverLink b) we don't need this comment but I guess you could add an nsIXULBrowserWindow heading instead to make it clearer.

>+               .filter(function (tag) tag.length > 0); // Kill empty tags.
[filter(function(tag) tag) would probably work.]
Comment 5 Robert Kaiser 2010-11-18 06:47:07 PST
Landed as http://hg.mozilla.org/comm-central/rev/65159580f815
Comment 6 Philip Chee 2011-01-26 04:24:49 PST
*** Bug 609034 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.