Confusion between "My Requests" and "My Bugs"

NEW
Unassigned

Status

()

Bugzilla
User Interface
--
minor
7 years ago
3 years ago

People

(Reporter: Filipus Klutiero, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101030 Iceweasel/3.6.12 (like Firefox/3.6.12)
Build Identifier: 

When trying to find a bug I filed, I couldn't use "My Requests" because it listed none, for my user chealer@gmail.com, as can be seen: https://bugzilla.mozilla.org/request.cgi?action=queue&requester=chealer%40gmail.com&product=&type=all&requestee=chealer%40gmail.com&component=&group=type

Yet I do have a bug filed: https://bugzilla.mozilla.org/show_bug.cgi?id=497202

Reproducible: Always
Requests are for flag requests, not filed bugs. Try the "My Bugs" link in the bottom footer.
Assignee: nobody → attach-and-request
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: Other → Attachments & Requests
OS: Linux → All
Product: Websites → Bugzilla
QA Contact: other → default-qa
Hardware: x86 → All
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
I found the problem. In fact, I was not looking at the right page.

There are 3 similar links: Reports, My Requests and My Bugs. Reports has nothing user-specific. My Requests is the page I looked at, My Bugs is the one I wanted. I had an hesitation when clicking My Requests, remembering it used to be called My Bugs, but I took it as I didn't see My Bugs. The reason is very simple; there are 2 links bars, one at the top and one at the bottom. The top one is missing My Bugs.

I don't know what My Requests is for. "My Bugs" should presumably be renamed "My Reports" or "My Issues" as it's not only for bug, but this appears to be a widespread terminological issue. It should be more obvious on the Request Queue page that a bug report is not considered as a request, and possibly tooltips explaining what each link is for. My Bugs and My Requests should be next to each other to avoid this kind of confusion.
(Reporter)

Comment 3

7 years ago
Reed, you are right (I guess, since I don't know what a flag is). Could someone retitle this to "bugzilla.mozilla.org: confusion between My Requests and My Bugs"?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Assignee: attach-and-request → ui
Component: Attachments & Requests → User Interface
Summary: bugzilla.mozilla.org: "No requests." searching for My Requests → Confusion between "My Requests" and "My Bugs"

Comment 4

7 years ago
We won't rename My Bugs to My Reports, because reports are something else.
Severity: normal → minor
Version: unspecified → 3.6.2

Comment 5

7 years ago
I think the request is actually to change "My Requests" to "My Flag Requests". 

The My Bugs vs My Issues is actually up to whomever sets up the Bugzilla Instance. By default a record is called a "Bug", it is trivial to change it from "Bugs" to "Issues", or "Records", or "Tickets". I believe the documentation explains this. As far as why BMO uses Bugs... Tradition?

I agree the text on the My Requests page isn't very clear that it is referring to Flags. I also like the idea that if you have no requests or are not logged in that "My Requests" might not show up or have some more useful text, however, since the search interface is really not easy to use to search for flags I think we'll have to keep this around for not logged in users.

This also is points out an ongoing issue that Flags are generally not understood by many novice users.

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

3 years ago
> I think the request is actually to change "My Requests" to "My Flag
> Requests". 
 
> I agree the text on the My Requests page isn't very clear that it is
> referring to Flags.


> This also is points out an ongoing issue that Flags are generally not
> understood by many novice users.

Agreed on all three counts. We have users wondering about My Requests in this bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=417702
You need to log in before you can comment on or make changes to this bug.