Wrong version being displayed on extension download page

RESOLVED FIXED in Q1 2011

Status

addons.mozilla.org Graveyard
Public Pages
--
major
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: Wladimir Palant, Unassigned)

Tracking

unspecified
Q1 2011

Details

(URL)

(Reporter)

Description

8 years ago
I had to pull Adblock Plus 1.3 because of an issue and upload Adblock Plus 1.3.1 instead. The problem is, even after moving Adblock Plus 1.3 into sandbox The download page (https://addons.mozilla.org/en-US/firefox/addon/1865/) would continue to list it (as "non-reviewed"). So I removed that version 1.3 altogether. However, now Adblock Plus 1.2.2 is being displayed. https://addons.mozilla.org/en-US/firefox/downloads/latest/1865/addon-1865-latest.xpi link results in Adblock Plus 1.3.1 being downloaded however and Firefox bails out because of hash mismatch.
(Reporter)

Comment 1

8 years ago
Same issue affects Element Hiding Helper - a regular release there without any issues. Element Hiding Helper 1.1 has been uploaded about four hours ago. https://addons.mozilla.org/en-US/firefox/addon/4364/versions/ shows it correctly. However, https://addons.mozilla.org/en-US/firefox/addon/4364/ still shows Element Hiding Helper 1.0.6 even though the download link serves up the new version (and causes a checksum mismatch).
(Reporter)

Comment 2

8 years ago
Both versions display correctly now - probably because I edited add-on descriptions, or maybe this is just supposed to take longer than what I am used to. However, if it is the latter then breaking downloads for several hours should still be undesirable.
The front end (python) doesn't know about the backend (PHP) so there are weird caching issues.  Regular uploads should be fine, but reverting to old versions and such is a bit undefined right now.
Target Milestone: --- → Q4 2010
(Reporter)

Comment 4

8 years ago
There was no reverting or such for Element Hiding Helper.
Target Milestone: Q4 2010 → Q1 2011
This was fixed when we switched /downloads over (bug 591028).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.