Redirect loop while installing add-ons; Install fails with -228

VERIFIED FIXED in 5.12.2

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

Dependency tree / graph

Details

(Whiteboard: [z], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 488013 [details]
headers

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

steps to reproduce:
1. Load https://addons-next.allizom.org/en-US/firefox/addon/9450/
2. Try to install the add-on and look at the headers.

observed behavior:
Install fails with -228 error. Headers show an redirect loop which goes on forever.
(Reporter)

Updated

7 years ago
Blocks: 591028
(Reporter)

Updated

7 years ago
Summary: Redirect loop while installing unreviewed add-ons; Install fails with -228 → Redirect loop while installing add-ons; Install fails with -228
(Assignee)

Comment 1

7 years ago
> Location: https://addons-next.allizom.org/en-US/firefox/downloads/file/79133/advanced_address_bar-1.06-fx.xpi?src=addondetail
> X-Powered-By: PHP/5.2.9

This shouldn't be hitting PHP.
(Assignee)

Comment 2

7 years ago
1. https://addons-next.allizom.org/en-US/firefox/downloads/file/79133

(removing the locale, I don't know why it's in there to begin with)

2. Location: https://addons-next.allizom.org/firefox/downloads/file/79133

(served by PHP)

3. Location: https://addons-next.allizom.org/en-US/firefox/downloads/file/79133

oremj: what's the rewrite we have here?  Why is the last one hitting PHP?
(Assignee)

Updated

7 years ago
Depends on: 608392
(Assignee)

Comment 4

7 years ago
/:app/.* was bouncing off remora instead of zamboni.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

7 years ago
Sorry for the bug spam, but-

Worksforme -> Cannot reproduce the bug reported using STR

This bug was "fixed" by having IT fix the core problem (see the blocking bug for details)
Resolution: WORKSFORME → FIXED
(Reporter)

Comment 6

7 years ago
verified.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.