Closed Bug 609705 Opened 9 years ago Closed 9 years ago

disable Android release updates

Categories

(Release Engineering :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aki, Assigned: aki)

References

Details

(Whiteboard: [automation][releases])

Attachments

(2 files, 1 obsolete file)

Assuming that we're sticking with apks and not switching to MARs any time soon, we need some sort of automation for the manipulation and movement of snippets on AUS2.

We're softlinking our way to success right now.

We should check on the status of Android updates -> MARs before putting significant effort into this.
Per Mark Finkle, we're letting the Market do Android release updates (betas, releases).

This bug now tracks the relevant config changes: mozconfig, turn off Android release snippet generation/pushing, update docs.
Assignee: nobody → aki
Priority: P5 → --
Summary: automate Android AUS snippet manipulation → disable Android release updates
Attached patch untested patch (obsolete) — Splinter Review
Comment on attachment 510308 [details] [diff] [review]
untested patch

I'm just toggling this off, not tearing out any code.
Do you have a preference about this?
Attachment #510308 - Flags: review?(nrthomas)
Thought about this just when I clicked "submit".
Attachment #510308 - Attachment is obsolete: true
Attachment #510368 - Flags: review?(nrthomas)
Attachment #510308 - Flags: review?(nrthomas)
Comment on attachment 510368 [details] [diff] [review]
same, but with staging + testing

Looks fine without drilling really deep into the code.

>diff --git a/mozilla2/mobile/android/mobile-browser/release/mozconfig b/mozilla2/mobile/android/mobile-browser/release/mozconfig
>-ac_add_options --enable-updater
>-ac_add_options --enable-update-channel=beta
>+#ac_add_options --enable-updater
>+#ac_add_options --enable-update-channel=beta

Bug 619801 tried to do this too, but the mozconfig would have over-ridden that. Probably worth dropping a comment over there if that's not already known.
Attachment #510368 - Flags: review?(nrthomas) → review+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
This tripped up FF4.0beta5 because of no feedback button, caused by no beta channel, caused by this bugfix. 

Discussion in mobile meeting continues on what is exact wanted behavior. Reopening, and cc-ing people who had opinions in meeting.
Blocks: 633375
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Please revert the mozconfig changes here
Attachment #513171 - Flags: review?(aki) → review+
Duplicate of this bug: 634910
Comment on attachment 513171 [details] [diff] [review]
removes commenting out for android updater in release mozconfigs

http://hg.mozilla.org/build/buildbot-configs/rev/cf2f141a05c5
Attachment #513171 - Flags: checked-in+
should be flagged to block beta5
tracking-fennec: --- → ?
ok
tracking-fennec: ? → 2.0b5+
Not blocking b5 anymore.
tracking-fennec: 2.0b5+ → ---
I think this is re-fixed.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Blocks: 674017
Blocks: 775849
We may want to verify that Socorro and metrics aren't dependent on the update channel being set before re-landing.
(In reply to Aki Sasaki [:aki] from comment #16)
> We may want to verify that Socorro and metrics aren't dependent on the
> update channel being set before re-landing.

iirc KaiRo said before that socorro is entirely dependent on update-channel being set.
Socorro is at least fully dependent on the channel being set in the expected way in crash reports. For beta, it *has* to be "beta", for release, we accept "release-*" and "default".
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.