about:Firefox has "check for updates" even when downloaded from the market

RESOLVED DUPLICATE of bug 766636

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 766636
6 years ago
5 years ago

People

(Reporter: blassey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
We can disable the updater code in the mozconfigs; we even did this once but backed it out because of problems with the feedback extension (bug 609705).  We don't ship that extension anymore, so perhaps we can re-land the mozconfig change.
Depends on: 609705
FYI, removing mozconfig lines like 'ac_add_options --enable-update-channel=beta'
will change MOZ_UPDATE_CHANNEL to default, which may still play badly with some of the ifdef's in
 http://mxr.mozilla.org/mozilla-central/search?string=MOZ_UPDATE_CHANNEL
and affect the blocklist ping (ie ADI metrics).
Why not just remove the code in about:firefox based on channel?

Updated

6 years ago
Duplicate of this bug: 787507
What if it said 'there is an update available, but you have to go to the market to get it'?

Comment 6

5 years ago
Some people have been confused by this button. See the story in bug 820309 and https://twitter.com/rem/status/278448554438184960

(In reply to Geoff Lankow (:darktrojan) from comment #5)
> What if it said 'there is an update available, but you have to go to the
> market to get it'?

Something along these lines sound right to me.

Updated

5 years ago
Duplicate of this bug: 820309
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766636
You need to log in before you can comment on or make changes to this bug.