Last Comment Bug 610107 - svg/svgz vertical lines no longer rendering
: svg/svgz vertical lines no longer rendering
Status: RESOLVED INVALID
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.solaire-chauffe-eau.info/p...
: 610108 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-06 02:42 PDT by ffux
Modified: 2010-11-06 07:39 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description ffux 2010-11-06 02:42:04 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2) Gecko/20100212 Gentoo
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2) Gecko/20100212 Gentoo

This historic image (unchanged since it's creation) and similarly generated content that I use on a daily basis with FF has stopped rendering in the last two weeks. It still renders correctly in Opera.


Reproducible: Always

Steps to Reproduce:
1. http://www.solaire-chauffe-eau.info/photos/albums/userpics/10001/150litres-080501.svgz
2. Look for vertical grid lines.

Actual Results:  
graph's grid shows no vertical grid lines.

Expected Results:  
vertical grid lines at similar spacing to the horizontal ones.
Comment 1 Robert Longson 2010-11-06 03:13:54 PDT
It renders perfectly fine for me on Firefox 3.6.12 on Windows. That is what you're using on Linux and not a Firefox 4 beta or nightly isn't it? Have you changed any other software like upgrading the version of cairo on your machine?

Does it work in safe mode? And/or with a new profile?
Comment 2 ffux 2010-11-06 06:18:35 PDT
yes this cairo update would match about the time things started screwing up:
x11-libs:cairo-1.10.0-r3:20101024-190935.log

I have not updated FF 3.6 in that period so this may well be it. 

I'll revert that and see. thx.
Comment 3 ffux 2010-11-06 06:26:51 PDT
*** Bug 610108 has been marked as a duplicate of this bug. ***
Comment 4 ffux 2010-11-06 06:28:06 PDT
Yes, reverting to x11-libs/cairo-1.8.10 fixed the problem. This needs looking into.
Comment 5 Robert Longson 2010-11-06 07:39:01 PDT
You should take this up with Gentoo I suppose. Firefox by default builds with it's own internal cairo that is tested to work with it.

Note You need to log in before you can comment on or make changes to this bug.