Closed Bug 610262 Opened 12 years ago Closed 11 years ago

SeaMonkey 2.1.x with Firefox compatibility detected as Firefox version 2.1.x

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 671085

People

(Reporter: stevew, Unassigned)

Details

This is semi-related to bug 594578, but deals with the addon pages themselves, rather than just the starting page.

If you navigate to a URL like this:
https://addons.mozilla.org/en-US/firefox/addon/722/

You are told it is "Not available for Firefox 2.1b2pre" although it works correctly from the Seamonkey listing:
https://addons.mozilla.org/en-US/seamonkey/addon/722/

On the other hand, if you browse an addon that is compatible with Firefox 2.x, but NOT Seamonkey, it incorrectly thinks it is compatible:
https://addons.mozilla.org/en-US/firefox/addon/2455/
The 2.1 version of SeaMonkey, where this is on by default, is about to be released next week or so. Could this be addressed? I think all it needs is to check for any other token in the UA before checking for Firefox.
Duping with bug 671085, which has a little more information.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671085
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.