Invalid character encoding when forwarding directly from message list

RESOLVED DUPLICATE of bug 597369

Status

Thunderbird
Folder and Message Lists
--
minor
RESOLVED DUPLICATE of bug 597369
8 years ago
8 years ago

People

(Reporter: Pavel Pola, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.2.12) Gecko/20101027 Lightning/1.0b2 Thunderbird/3.1.6

I've received an e-mail with character encoding:

Content-Type: text/plain;charset=iso-8859-2
Content-Transfer-Encoding: 8bit

When I forward it directly from the message list, the national characters in new message window are completely wrong. 

When I open the original message in message window and forward it from this window, national characters are ok.

Reproducible: Always

Steps to Reproduce:
1. have an e-mail in iso-8859-2 in the inbox message list
2. click on forward button directly from the message list

Actual Results:  
you should now see a new message window with bad character encoding

Expected Results:  
I suppose to have the correct encoding either I forward the message directly from the message list or from the message detail window

I'm using the czech localization of Thunderbird.
(In reply to comment #0)
> When I forward it directly from the message list, the national characters in
> new message window are completely wrong. 

What operation do you call "forward it directly from the message list"?
While a mail is selected at message list(thread pane) and the mail is shown at message pane, right click other mail, choose forward at context menu of the other mail?
If so, dup of bug 597369?
(Reporter)

Comment 2

8 years ago
I'm not using the message pane - so my whole workspace is covered by the thread list (and folder list, for sure). The problem is when I click in the thread list on a message and select Forward. When I open the message in new message window and then I click Forward everything seems to be okay. 

And it looks like a duplicate of mentioned bug. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 597369
You need to log in before you can comment on or make changes to this bug.