Black filled text fields on Gmail login page.

RESOLVED DUPLICATE of bug 637828

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 637828
8 years ago
7 years ago

People

(Reporter: Anna (Waverley), Assigned: jrmuizel)

Tracking

({mobile})

Trunk
ARM
Android
mobile

Details

(Whiteboard: [needs-cairo-update], URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101104 Firefox/4.0b8pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101107 Firefox/4.0b8pre Fennec /4.0b3pre

On the Gmail login page, a part of the "Username" and "Password" text fields are filled black.

Devices: Motorola DROID 2, Samsung Galaxy S Captivated

Reproducible: Always

Steps to Reproduce:
1. Clear all private data.
2. Go to the Gmail login page
3. Tap on "Username" field.
4. Tap on the Down button on the screen.
5. Tap on the Down button on the screen.
   

Actual Results:  
The "Sign In" button is selected and highlighted, but a part of the "Username" and "Password" text fields are filled black.

Expected Results:  
The "Sign In" button should be selected and highlighted and the "Username" and "Password" fields should remain unchanged.
(Reporter)

Comment 1

8 years ago
Created attachment 488840 [details]
Actual results
tracking-fennec: --- → ?
Jeff, we're assuming this is some gfx layers problem, could you have a look?
Assignee: nobody → jmuizelaar
tracking-fennec: ? → 2.0+
Duplicate of this bug: 611533
Duplicate of this bug: 621613
This is on facebook.com and pretty much any login form.
Severity: minor → normal
Hardware: Other → ARM
OS: Other → Android
This seems a little like bug 627772
(In reply to comment #6)
> This seems a little like bug 627772

We do use border-radius on textboxes and buttons, but instead of box-shadow, we use linear gradients for the background. I don't know if this bug is really related or not.

Updated

8 years ago
Duplicate of this bug: 633876
Created attachment 513558 [details]
Screenshot of AMO

Here's another example.
^^^ http://addons.allizom.org/

It is reproducible on Android, but doesn't seem to be on Desktop.
OS: Android → All
OS: All → Android
(In reply to comment #10)
> ^^^ http://addons.allizom.org/
> 
> It is reproducible on Android, but doesn't seem to be on Desktop.

Note that you need a Fennec user agent to see the mobile version of AMO; otherwise you'll get the normal desktop version.
(In reply to comment #11)
> > It is reproducible on Android, but doesn't seem to be on Desktop.
> 
> Note that you need a Fennec user agent to see the mobile version of AMO;
> otherwise you'll get the normal desktop version.

By "desktop" stechz probably meant the desktop build of Fennec.
Jeff, this is currently assigned to you, can you please put together a plan of attack for this? We consider this a hard blocker for fennec.
(Assignee)

Comment 14

8 years ago
Can someone make a reduced test page showing this problem?
Keywords: mobile
I can't reproduce this anymore. I'm going to resolve as works for me and ask that QA (Anna?) make sure they can't reproduce anymore either before verifying.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
I can reproduce this still on today's (...0228) fennec nightly.  It happens quite often if you browse around on addons.allizom.org.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 17

8 years ago
There is a fairly consistent bit of smudging on the mobile addons.allizom.org- pieces of mispainted UI in either black, or other bits of the page. I don't think we're doing anything non-bog standard. It's sporadically occurring on scrolling.
I wonder if this is a problem with an active layer being created for the opacity change and being destroyed immediately. We seem to be seeing something like this in bug 637828.

Updated

8 years ago
Duplicate of this bug: 637823
Matt - Can you make a build without the content css opacity and get it to Wil?

Comment 21

8 years ago
would you also like gradients with opacity and box-shadows removed?

Comment 22

8 years ago
https://github.com/potch/zamboni/tree/mobile-opaque

This is a branch of the mobile site without gradients, box-shadows, opacity, or rounded corners. I went through and removed each "type" of effect one at a time, and tested on a phone between each. I saw the issues on the site as before until I got rid of our gradients. Now, I only see the black spots on the native form controls, which seem to have gradients defined at the system level :)

That branch is (unfortunately) not available on any server right now, but the relevant diff is here: 

https://github.com/potch/zamboni/commit/b7efd2292
Status: REOPENED → NEW
And here's a build of Fennec for Android without gradients in form controls;
http://people.mozilla.com/~mbrubeck/fennec-4.0b6pre-mbrubeck-no-gradient.apk
(In reply to comment #16)
> I can reproduce this still on today's (...0228) fennec nightly.  It happens
> quite often if you browse around on addons.allizom.org.

Wil - Can you try Matt's build:

> And here's a build of Fennec for Android without gradients in form controls;
> http://people.mozilla.com/~mbrubeck/fennec-4.0b6pre-mbrubeck-no-gradient.apk
To be clear, I expect my build will only fix black areas showing up in textboxes and other form controls.  To fix most of the black showing up on addons.allizom, I think you need the other Matt's changes.  :P
(In reply to comment #24)
> (In reply to comment #16)
> > I can reproduce this still on today's (...0228) fennec nightly.  It happens
> > quite often if you browse around on addons.allizom.org.
> 
> Wil - Can you try Matt's build:
> 
> > And here's a build of Fennec for Android without gradients in form controls;
> > http://people.mozilla.com/~mbrubeck/fennec-4.0b6pre-mbrubeck-no-gradient.apk

I tried installing it.  It downloaded, said it would replace minefield, and I said alright.  It did looked like it was going and then said "Application not installed" with an [OK] button.  I'm not sure how to debug it further.
This usually happens with Android. The best thing to do would be to uninstall the old version and try installing this version. I tried, and it installs perfectly.
That build works as expected - black areas still show up on allizom, but I didn't see them on the form elements.
Updating cairo fixes this.
Depends on: 562746
Whiteboard: [needs-cairo-update]

Updated

8 years ago
No longer depends on: 638594

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 637828
You need to log in before you can comment on or make changes to this bug.